Please help! Trust wallet SOL issue

Hi All, any insight would be greatly appreciated. I tried sending STAR ATLAS coin from Trust wallet to the exchange.

Right as I clicked send, I saw “15,000” SOL flash up almost like a glitch. I figured it was nothing and saw my Atlas never sent. So I proceeded to try three times as my ATLAS was not sending. As I scrolled down I saw there was 3 pending transactions on SOL & they show no data at all. No transaction, no nothing, just says “pending” and it’s been over a week and still sitting in pending stage and no data on block explorer.

The weird part, is when I go into SOL on my trust wallet, the three pending transactions say I was trying to send 15,000+ SOL for each pending transaction. But that’s not true as I have less than $100 of SOL in that wallet! How do I erase these pending transactions and get them to go away so I can send my ATLAS coins to the exchange??

Anyone else experience something like this? If so, what do I do as a next step? Thank you in advance!

1 Like

@Crypto1234 You should submit a support ticket from your Trust wallet app.

Settings → Support
or at

To reduce response times from customer support, please include the following info in the ticket:

App version, device model, wallet address, TX hash (if available), and the blockchain + assets you’re experiencing the issue with, and any relevant screenshots or videos to duplicate the error.

I figured a way. I imported my 12 word seed phrase to solflare. I then transferred my star atlas to an exchange and it worked right away. I check my trust wallet and I could see the transaction went through.