Problem sending $ATOM

I have a problem sending $ATOM. Even though I have enough to cover the transaction fee, it doesn’t calculate it correctly. Because of this, it is impossible to make a transaction. I don’t see where and if I can adjust how much the fee is.


Hello @lujo
Please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, then attach it here)

  2. Crypto wallet address (press the receive icon near the send button, copy and paste it here in plain text)

Heads up! Please be informed that we will never ask for your seed phrase or money; talk to you via email, WhatsApp, Telegram, or other platforms. Be vigilant against scammers and impersonators, and report them to us immediately.

1 Like

Having the same exact issu so Im assuming its something messed up during the update.



Trust Wallet app version is 8.2.7
I can’t add screenshoot.

But the same problem is with both the application and the extension, and the extension is also upgraded.


I have the same problem too. Both sending and staking.

App: Version 10.2 (838)

Address: cosmos12dsexf507h6xmc7xjk4xqxvmt35st62mdc68d8

1 Like

@lujo, @dank14, @Earlet The issue with cosmos is being looked into, an app update with a fix will be released.


Hello good day please I have a problem and I’ll appreciate your help…I sent btc to another wallet from trust wallet for over 3 days now and it’s still pending in the Blockchain buty money is still in my wallet bit I can’t transfer out coz of mempool conflict error

My wallet: bc1qtcvxgp4apcftp7t4haswryz7d0zdgtg3za7xpj

1 Like

@Xxholysinnerxx You’d need to wait till the BTC is confirmed sent or dropped back to your wallet.

1 Like

How long can it take to h dropped back to my wall t…I have been on this since 17th…saw something about increasing the gas fee that it’ll overide but it still doesn’t work

1 Like

It looks like the issue has been resolved for me atm. I was able to finally send ATOM to an external address.

1 Like

The app has been upgraded, the problem with cosmos has been solved. Thank you.

1 Like