Problem with TrustWallet and Wallet Connet

I have found ways to fix it each sometime. It has took a couple days one time. Is there a way to prevent the need to flush dns to fix it? Sometimes just clearing the cache does not work. Anyone found a way or does anyone else have the problem of trying to scan but it does nothing?

I have some eth to get out of a eth dapp and when I scan it and click approve it kicks me out. That is a seperate issue. Looking for a fix to this.

Hey @iamdeadlyz I am experiencing this problem also. I noticed it happens mostly on android devices as I know someone else using android with this problem and swapping to an iOS device resolves the issue. I have a Samsung S10e and the app version is 1.22.24. I am trying to connect to UniSwap, this site will not let me include the URL. When you click on ‘Connect Wallet > WalletConnect’ and scan the QR, on an iOS a pop up displays for approval, this pop up does not display on my android

Hi @Detro10 & @Ken90, please respond to my previous question so I can understand further.

A post was split to a new topic: Feedback about the app

A post was split to a new topic: Get DApps browser on my iOS

A post was split to a new topic: Cannot approve Rarible transactions with my Trust Wallet

Hi, I have an issue with approving my deposit of BIFI into the Beefy Finance BIFI Maxi Vault. The “send” button is greyed out, and the amount confirmed is -0. Please could you help? Thanks.

Hey I am actually having the same problems with swapping on Uniswap as well.

I am having the exact same issue. I have tried everything… Updating my app adding the Dapp future, nothing. I’m on an ios can some please help me @iamdeadlyz

@iamdeadlyz now after getting the Dapp version it out takes me to my wallet but now I get the Something went wrong… try again message.

@iamdeadlyz now after uninstalling the app and reinstalling it I no longer have the Dapp version I go to pancake swap type in my order and submit. The waiting for confirmation symbol comes up and I am redirected to my Trust wallet where nothing happens… Please help.

Hi @vocathy17,
To better assist, please provide us the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)
  2. Crypto wallet address (press the receive icon near the send button, take a screenshot, and attach it here)
  3. Transaction hash or link (if you have any)
  4. Further details about your issue (please explain what you were trying to do)
  5. Screenshots of the wallet (including errors, if any

@Eazy, please follow this guide so you can enable the DApps browser:

Update… I started running pancake through safari and it worked just fine… but initially I was running it through chrome and it worked fine the first time but all of a sudden I stoped getting the signature confirmation button in my trust wallet.

But everything seems to be working fine now that I’m running pancake through safari. Thank you for getting back to me.

Glad to know it’s working fine now, @Eazy. Though I highly recommend that you use the built-in DApps browser of the Trust Wallet app to avoid future issues. You can follow the guide that I sent earlier so you can enable it. Cheers~

I’m having this same exact issue even after enabling DApp through the link. Not sure what to do, im using safari browser as well on iPhone. keep getting a “something went wrong” error right at confirmation. Please help!

Hi @simmyyy,

Since you already enabled the DApps browser, use it instead of Safari, to avoid any issues.

But I’m having to use safari for pancakeswap, maybe I’m a little confused as I’m new to this. But when I initiate the swap on pancakeswap (in safari browser on my phone) it redirects me to the trust wallet app so I can confirm the swap but instead Another link to get to trust wallet comes up & when I click that link it’s broken.

Do not use the safari. Open the Trust Wallet app then select the icon with 4 squares (with the name “DApps” located in the bottom.


Omg it worked!! Thank you so much for your help. I had no idea I was able to access pancakeswap through the app

1 Like