Sent FTM Token From Native FTM Network

I recently sent FTM tokens from my Exchange account to my trust wallet.I am Use Native FTM Network.(No ERC20 and No Bep2) . I have received confirmation of the withdrawal from Exchange but there is no recognition from my Trust wallet receiving these tokens. It was sent using the Native FTM network . Can You help me? My FTM Trust wallet address is: 0x7F1C9Eb0cED1D7961Fd9581A87d5A8862e16C59F
I Test your Solotion about Recover Trustwallet. but Do.nt Show Ftm Token Yet.

sucsess fantom network hash:


sucsess fantom network link:

(Fantom Transaction Hash (Txhash) Details | FtmScan)

hi, I cannot help you. I have the same problem transferred the coins to the erc20 address. tried using the fantom bridging tool but get lost at the end, In fact, it might be easy for you as did you use Binance exchange. Just asking if you have found a way to solve the problem. I am heading over to Redditt to see if they can help.

Currently got exactly same problem - FTM has been sent, 4 days ago, shows transcation complete, done all checks had all info correct and it’s still not showing up in Trust Wallet??? - can someone help?

Hi @esmaeilgorzin, @K9slayer, and @wes2021,

Be informed that the Trust Wallet app does not support the native FTM.

To retrieve it, please get your recovery phrase (here’s a guide: How to Backup a Multi-Coin Wallet), then, import it to their official wallet (choose mnemonic phrase): Fantom fWallet

1 Like