Smart Contract Call Again...but...

I am now one of the legions of Trust Wallet users getting this Smart Contract Call message, fees taken, no swap happening…never seen this problem in any other wallet or exchange and I’ve done enough with ETH to know it’s not “its system”.

I have ETH in my wallet… I had DAI in my wallet. Having tried all the fixes recommended - only to have the “fees taken-no execution” scenario continue, thought I’d try one more time since each time my original coins were still there, minus fees. Set it up, my DAI going to my ETH on TW…hit swap. Zero Eth arrived although it says “success”. But this time all of the DAI is gone, vanished, zeroed out.

Is it time to abandon TW or is there something we all are obviously missing?

And yes, glad to share screen shots…but unless my coins were “appropriated” from within the closed Trust Wallet system - not sure how to get my value back.

2 Likes

Hello @MLuchy,

Double-checking, did this thread help you understand further?
:arrow_forward: I only approved the RSR token to spendable. What should I do next? - #5 by MLuchy

First, kudos on being a great communicator and reference in this community. Best answers I’ve seen. Second, I hope I’m smart enough to follow the answers needed. I’m hoping my problem is as simple as I sent it to myself and I just don’t know it. Version 5.15, approved when asked, swapped when asked, never had to copy or type in an address to get it wrong - as everything was within my account of TW.

Side question: Does WalletConnect work with Binace.us or only Binance.com?

Neither. Those are centralized exchanges. You can connect it with Binance | Dex Trading | Decentralized Exchange | Binance.org, which is a Binance DEX.

1 Like

A more direct response to your question about the thread… no, the thread did not add knowledge to my situation. My ETH in TW says “success” on the transfer with the “smart contract call” and 0 Eth showing up. My DAI is gone. Ideas on where the coins/value might have gone?

1 Like

Please send me the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)
  2. ETH wallet address (select Ethereum, press the receive icon near the send button, take a screenshot, and attach it here)
  3. Transaction hash or link

Hello IMDL,
I responded last week directly to your email. In that I haven’t received a response, I’ll assume I was to direct this to the TWCommunity site. I’m still trying to figure out what happened to all my DAI tokens that were sitting in TW. Swapped them to the ETH in my trust wallet - Eth fee charged, “success” declared, nothing arrived in ETH, but this time all my DAI is gone - not just the fee over and over again. I would like to swap more for ETH but with 4 or 5 “Smart Contract Calls” each time taking a fee but not sending the crypto - I’m dumping $100’s of dollars and getting nothing accomplished. Please help with what’s happened and how to correct this. MLuchy

![IMG_6763|281x499](

upload://7u2melTYFhSun2kMRoKgXxD7nEd.png)

Here are the additional photos that didn’t attach to the first group sent.

ML

Thank you for providing the requested details.

Upon checking, you successfully swapped DAI to ETH: Ethereum Transaction Hash (Txhash) Details | Etherscan

The app won’t display it as received in the Ethereum page since an internal transaction was done so you can receive the ETH. You can check here instead: Address 0x7a0b5e5b723bcf8fa51c828e479423ddf5878e40 | Etherscan

A post was split to a new topic: Swapped bnb smartchain today and did not have the funds show up in my account

Hey I’m having the same issue. Is too many people trying to do it at the same time what’s the issue?

I’ve just tried sending you screenshots but it says I can’t send them in the message?

Try to attach the necessary screenshots again. For reference:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)
  2. Crypto wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here)
  3. Transaction hash or link (not a screenshot, but a copy paste)
  4. Further details about your issue (please explain what you were trying to do)
  5. Screenshots of the wallet (including errors or missing balance)
1 Like

Thank you for all the info. It seems to have sorted itself. It’s in the right place now.

1 Like