Staked TRX and now cannot unstake

I know a lot of other users have had this same issue, and I have tried the methods suggested to help them on their threads. However, nothing is working for me.

I have TRX in my Trust Wallet, which I staked using the built-in staking in Trust Wallet. The stake period was 3 days, and it has been over a week, and I can still not unstake.

When I tap “unstake” or “claim rewards” in the Trust Wallet app under TRX, it just gives a dialogue box saying “Not available”.

I do have 36 available TRX (unfrozen TRX), so I have enough to pay for gas fees.

I do not remember which validator I staked with if anyone is wondering.

My main questions are these:

  1. How do I unstake my trx if I keep getting this error?
  2. How do I view how many rewards I’ve accumulated from staking so far if I keep getting this error?
  3. Is it possible my TRX could be stuck forever?

I have attached screenshots of my address, my Trust Wallet version, and the dialogue box that appears when I tap “unstake”/“claim rewards”.



I have also submitted a ticket in the support section of Trust Wallet, however, it has been 10 days and I have yet to receive a response from them.

If anyone can help it would greatly be appreciated. Thanks!

1 Like

Hey @connova
Did you try reimporting your wallet then try to unstake again.

Also update, my Trust Wallet version has updated to 2.11, it’s no longer 2.7 like the screenshot.

Hey @JennyMillan

I just uninstalled Trust Wallet, reinstalled it, and then imported my wallet using my seed phrase.

I still have the same issue.

Hello @connova you TRX are not staked but frozen. To unfreeze them, You have to stake whole amount of frozen TRX and wait for 3 days then unstake unstake, they’ll be available.

Read how to stake TRX here: How to Stake TRON (TRX) on Trust Wallet

1 Like