Stuck pending re imported wallet

Hi I’ve tried to send sol back to Binance wallet and was pending for a very long time. I hit the more button and transaction didn’t show. I’ve since followed suggested backing up and re import wallet , this cleared pending transaction along with my previous deposit transaction history. My balance is still showing with no history. I tried sending to Binance wallet again but failed. My address DzUhrXeSYjtyKnx2auTJZHUGeP2LVeYgJmkeGw1wFRzF
Many thanks

Hello @Gee,

To better assist, please provide us the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)
  2. Solana wallet address (select Solana in the Trust Wallet app, press the receive icon near the send button, take a screenshot, and attach it here)
  3. Transaction hash or link (please copy and paste, not a screenshot)
  4. Screenshots of the wallet

Hi thanks for reply please see attached…

You don’t have any pending transactions: Explorer | Solana

Please re-import your wallet and try again:

Thanks il try re importing and sending :+1:

Your SOL tokens are still in your wallet: Explorer | Solana

Since you are using 4G (mobile data), please try to use WiFi with a strong internet connection. VPN could help as well if it still doesn’t display the correct balance.

I’ve just checked again and balance is restored thanks again for your help :+1:

1 Like

Sorry to bother again I’ve copied address from Binance and tried to send I got these messages?

Thank you for letting me know. This issue is now relayed to the dev team. Let’s wait for their updates.

1 Like

@Gee, per advise by the dev team, please try again later (perhaps, a few hours) as there were problems with the Solana nodes earlier.

1 Like

Thanks il try later :+1:

Hi I was wondering if the solana node problem has been resolved?
Thanks

Just on the above. all is good and everything went through ok thanks for your help :+1:

1 Like