TerraUSD - insufficeint fees attempting to send

I have terraUSD in my trust wallet and have attempted to send from wallet to exchange. However i receive an error starting with the following caption:
insufficient fees;got: “19830uusd”, required…plus more.

Any help greatly appreciated


Hello @Hansmoleman To better assist, please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)

  2. Crypto wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here. Also copy and paste it in plain text)

  3. Transaction hash or link (if you have any, please copy and paste)

  4. Further details about your issue (please explain what you were trying to do)

  5. Screenshots of the wallet (including errors or missing balance)


Hi Alan

See attached photos and address below.


I have tried sending to both Terra station and an exchange and get the same error. Have tried sending different amounts but that doesn’t change anything either

1 Like

@Hansmoleman you need some LUNA too for transaction fees.


Ok I have added some Luna now and tried to send but received same error.

1 Like

Looks like similar error just different phrasing. Have finds in both Luna and Terra Ust

1 Like

I have the exact same error, have Terra USD (UST) in my account but an unable to send.

The error messages are similar. Should be relatively straightforward to test. The error messages don’t explain what’s wrong out what can be done to fix. I now can’t use my money.

1 Like

Android, app version 2.7

Am trying to attach an image but get an error message.


I have the same error:
Transaction error
"insufficient fees; got: “17121 uusd”, required: “484230uusd” = “”(gas) + “484230uusd”(stability: insufficient fee

The quoted network fee in the transfer window is 0.017121 UST so I assume that that is the 17121 uusd. Neither is keeping any amount of UST in the wallet to pay the network fee helpful.

Thanks for looking into this

I have same error. It doesn’t matter how much ust or terra i have left in the wallet after the amount i wan tot send


I have some luna in the wallet as well as the ust i want to send…doesn’t matter I still get the same error. Also on terra system fees can be paid in either ust or luna…not sure if trust wallet is the same


Hi Alan, I am new on this community chat. When there is an issue like we are experiencing with sending terra, wha tis the best way to get technical support…seems like this issue needs to be addressed by devs. Please advise, thanks you


Yeah it looks like a bug, our transactions should pass easily since this is the terra stablecoin. I hope the admins will give us a confirmation and update shortly; since we can’t swap or trade this token here either our funds are essentially locked until this issue is fixed.

1 Like

I started a new thread with the info they asked for. Seems like it should be an easy fix…hopefully soon


Did your problem solve?
About ust and trustwallet7​:heart::heart::heart::heart::heart::heart::heart::heart::heart::heart::heart::heart::heart::white_heart::heart::white_heart:

I have same error …:open_hands::open_hands::open_hands::open_hands::open_hands::open_hands::open_hands::open_hands::open_hands::open_hands::open_hands::open_hands::open_hands::open_hands::open_hands::dizzy_face::dizzy_face::dizzy_face::dizzy_face::dizzy_face::dizzy_face::dizzy_face::dizzy_face::dizzy_face::dizzy_face::dizzy_face::dizzy_face::dizzy_face::dizzy_face::dizzy_face::dizzy_face::dizzy_face::dizzy_face::dizzy_face:zzzzzzzzzzzzzzzzzzzzz

Did your problem solve ?
I have same error​:speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon::speech_balloon:

Hello team has reviewed this issue and found the error is mainly due to gas fee estimation by the app.

New version of the app will be released with correct gas fee estimation.
Thanks for reporting and Sorry for inconvenience we’ve caused.

1 Like

I have a same problem and my app is updated
How can I fix it?
plz help me fast I need the ust