The balance of my ETH wallet is not updating correctly

Transaction Hash:

Wallet number:

I’ve sent 1100$ to my wallet. Etherscan tells me that transaction was successfully completed. And balance of my address is 0.488567559564252057 Ether

But what can I see in my Trust Wallet app? It’s only 0.05 ETH.


1 Like

Same problem here.
Tried deleting trust wallet and recovering. Cleared cache and everything. Still no success. But etherscan shows the correct balance.

I have the same problem
Wallet version 1.28.0
Sent 0.8 eth
Wallet adress 0xC67a3C06305fd86229a3E242962D1522B563EE16
Transaction hash
Etherscan confirmed transaction, this transaction displayes in trust wallet, but there are no available ETH balance

Please help

The same thing happened to me with LINK. Based on what I’m reading here it’ll eventually show up after a couple of hours.

1 Like

Can you click on this TX hash showing you there? and provide screenshot then… I’d like to see if the confirmations are on positive or in minus side.

Let me know Your Trust wallet app version (Click on setting > about & take an screenshot. attach It here.)

Showing negative confirmations for me. What does that mean?

Will it be sorted after a few hours?

the latest version

We have a node out of sync, Our team Is working on it. Please refresh the app, This problem should be resolved by now.

@MikhailMar @zenleaf @Lamotrigin @mclint
Kindly refresh the app guys. You balance should display in the app, now

Unclickable unfortunately

Refreshed app. No success. Version 1.28.1.

Confirmation count is still negative but getting closer to zero every second. So gonna recheck in 1hr.

I see,
Can you re-import the wallet?
How to Import a Wallet
I’ll let the team know anyway that , Refreshing app doesn’t working.

Did the re-import but no success.

Hoping it reflects correctly when my confirmations are positive.

Yeah, Just wait a few hours. Nodes are currently syncing. This will take some time.

My confirmations become positive and cost of transaction appears at wallet balance.
But i don’t like this situation all in all. Amazing time break do not goes positive for my business.

I sent ETH from my Ledger to TW at 550pm and its now 820pm and I still haven’t received it. The TW shows that its there but it doesnt come up in the balance. I can clearly see the transfer for +0.2306ETH and if i click on it I can see its completed with a link to Etherscan

Can anyone advise?