Tokens not visible

My Trust Wallet Version is 1.28.1
there was no error, i have the token in the list but it shows 0 accountbalance

Hi, Please try to add it as custom token. Here are the steps that you can do to manually add the token: How to Add a Custom Token

Already added the token, its showing in the list but the transaction is not coming in. On bsc the transaction shows success but the tokens dont arrive on the wallet

By the way thank you for your time I really appreciate your help. What about the transaction id? Is not able to use that somehow?

Hello, try the following :-

1 Update your app

2 Reimport your wallet. Here’s a guide: How to Re-Import your Wallet

3 Use VPN

Wow, thanks a lot, I will look into this. I will tell you if it worked. Thank you so much

When I bought, I couldn’t find the token on trust first, it was added after I bought, maybe thats the reason,

I tried but didn’t work. Everything restored, Balance still 0 coins, but everything else is back

So it took me some time to collect enough courage to try this. I did, I restored my wallet but the tokens still not there. I can see the transaction on pancake swap and on bsc scan. Pretty tricky, I hope you have another idea

Maybe my wallet adress was changed in between buying and adding the token. It took some time, token was not available first.

A post was split to a new topic: Swapped bnb to eth

Did you resolve your issue with the token? I have the ecact same problem. My GMR is not showing in my wallet and I think I did everything right just like it says in the post.

If it is a custom token did you add it with BEP20? when you set it up i think it shows ethereum by default

I had the same problem. I managed to resolve the issue somehow. I went back to the bscscan and found the GMR token contract address. I copied it and added it to my trustwallet again just like the first time and I could see the transfer took place. But now I have two GMR tokens showing. One is legit and other one is just showing 0. I hope this helps.

In my wallet it was BEP20 as default. Maybe someone has it different or something.

Yeah I resolved my problem thank you. I removed the token from my trust wallet and added it again and now my tokens are there.

GMR not showing in Trust Wallet. Bscscan says successful. Any help appreciated.

I cannot see the value of two of my tokens though on a friend’s trust wallet they can see the value on the exact same tokens

Hi @Hamka23 try to
try the following :-
1 Update your app

2 Reimport your wallet

3 Use VPN