Transactions for USDC to Eth keep failing

Hello Trust community.

I have been trying for days to swap US DC for Eth. I have tried Uniswap and Trust wallet and both have incomplete or failed transactions. To make it worse I keep losing Eth to Transaction and network fees.

I submitted one transaction that only cost $30 Eth and it did not complete. When I went back to try again, the transaction cost $100 to swap $500 USDC to Eth.

I have tried increasing gas fees, but this does not work.

Can someone tell me how to resolve this?

2 Likes

Hi @Microbusinessmedia,

To better assist, please provide us the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)
  2. Crypto wallet address
  3. Transaction hash or link (please copy and paste, not a screenshot)
2 Likes

The same thing has happened to me. I’ve only lost one transaction fee, but I won’t try again if I can’t trust it to work.

Hi @CryptoJeff,

Please give me the requested details as well ^

1 Like

App Version - 1.26.11
Ethereum Address - 0x2E180B4c7B34d9f3fE7dE5f197bA1802A5CC4270
Transaction Hash - 0x1c7fc3c170b822c02d217090ae8fbf3e09f0d320aa8b929055ca21ab4f74e511

Thank you for your quick reply and offer to help.

When swapping tokens for the first time, you have to approve it first to be spendable. And, that is what you did just now. Since you are done approving the token, you need to enter the amount that you want to exchange then press the swap button.

All in all, you will confirm two transactions: approve and swap

1 Like

Thank you so much! The Trust Wallet looks fantastic and I was very anxious to keep using it. I’m headed to swap now. :smiley:

1 Like

You’re welcome! Appreciate the feedback as well~

1 Like

Hi,

I was able to fix the problem by going into Metamask and changing the “Nonce” setting. Next I ran a small transaction with the maximum gas fee and it seemed to work. Im not sure if that was the actual fix, or it if just happend to start working.

The transaction kept getting approved, but it would just sit idle in “pending” status until it failed the next day.

Here is a 1 inch transaction approval, but it did pretty much the same thing on Uniswap and Trust Wallet.

https://etherscan.io/tx/0xe5ac6dc4c179587f542489e3bad1eecd95f7ee44f567707c15b4f04f67a892a3

Hello @Microbusinessmedia,

Before that transaction, you revoked USDC to be spendable on 1inch. That’s why you have to approve it again (hence you have that tx). https://etherscan.io/tx/0x2589a4f66019827bf0a1f4514241dddfb48e215f8fe02c57a598d8c20f9ec4b9

I rejected the transaction after it remained “pending” for hours. One transaction remained pending until the next day until I rejected it.

You need to make sure that you are using a high gwei for the network fees so that it will be confirmed as quickly as possible. You can use this for your reference: https://www.gasnow.org/