Transfered my coins another wallet - they didn't arrive


Around 2 hours ago I tried to transfer some coins from my Trust Wallet to Metamask. However, for some reason, the transfer didn’t occur fully and I received only 0.000000001 coin.

Is this correct?
Is it possible to reverse the transaction and have my coins back on my Trust Wallet?

Thank you in advance!

@gpontes To better assist, please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)

  2. Crypto wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here)

  3. Transaction hash or link (if you have any, please copy and paste)

  4. Screenshots of the wallet (including errors or missing balance)

Hash: 0x16c1781d9b18dc1caaa9e83ab0b0ffe882015bcb7f027306942ae200d487ede4

This last one is a print from my computer, because that’s where I manage my MetaMask wallet.

Also, through wallet tracking, you can verify that in my wallet I used to have a really big balance of the coin in question. I tried to transfer that amount. I have a total of 0 in my Trust Wallet, after said transaction:

Hello @gpontes Please be informed that the SAFEMOON devs have implemented a 100% tax on their old token.

Refer here:

For further inquiries, please reach out to them directly.

Alright, I’ll try to get in touch with them.
Thank you for your help! And have a great evening!