Trust Wallet: Swap button not activated in Pancake Swap

I have the problem, that i can’t sell anymore a token via Pancake swap. :frowning:
If i want to sell a token, then i will only get the following screenshot:

This problem i have not only with the Gravitoken; i have it actually with all token.
For example, if i would try to sell Refinable (FINE), then the left button would shown “Enable FINE” and the Swap button would be also inactivated.

This problem occurs since 5 days i think and i don’t know what’s the reason for this problem. I hope someone here in this forum has a good solution for this problem.

2 Likes

Hello you need to Enable it first before you can be able to use the swap button on pancakeswap.

1 Like

Thank u, I have just tested it with a very small amount at a different coin and it works. :wink:

But what i not understand: When i try to buy a new coin (e.g. swap from BNB to Refinable) there will directly the Swap-Button displayed on my mobile device (without the Enable FINE-Button).

So i don’t understand why there is a different behaviour in Pancake Swap for buy and sell a token.
Do u know why this is or have you got some background information for this procedure ?

I think, when i have sold a token in the past, i could directly push the swap button (without to enable this token button in a first step.
And this is sth. what i not undrstand yet. What could be the reason for the different behaviour compared to my sells in the past ?
Perhaps you have got an idea for this different behaviour ?

Some tokens require approving them before you can swap into other tokens.

1 Like

Ok, thank u for ecplanation.

I think, Gravitoken (GRV) is one of those token, which need prior approving, before it’s posibble to swap thiis token into another one (In my case: to BNB).

Thank u for offer a solution for my problem. :slight_smile: