Trying to swap all of my ETH, I can't proceed, why?

Hi there,

I would like to swap currencies with Uniswap using my Trust Wallet.

However, as soon as I click on Swap (in the Uniswap dApp), the Trust Wallet confirmation pops-up with a grey “Confirm” button so I cannot finish the transaction.

Some troubleshooting data:

  • dApp browsing/trust enabled and dApp browser icon showing up in the bottom menu of my Trust Wallet app (as described in the Basic section)
  • iOS 14.4
  • Trust Wallet 5.15 (5154)
  • Screenshot below
  • Tried it with two different currencies
  • Tried it using Chrome on my MacBook
  • Tried it using Safari on my MacBook
  • Tried it using Chrome on my iPhone
  • Tried it using Safari on my iPhone
  • Tried it using the dApp directly started in the Trust Wallet dApp browser

1 Like

Hi @m5s5j4g7pY857lt1E1Yw,

What is your ETH wallet address? (press the receive icon near the send button, take a screenshot, and attach it here)

1 Like

Please enable the DApp browser by following this guide:

Use this one instead of other browser apps.

Did this already without a positive result.
Still doesn’t work :grimacing:
Initiated the swap from the dApp browser but no sucess

Please send us a video recording of the issue while using the DApp browser (you can upload it via Google drive then share the viewing link here)

Tried it with Chainlink token (LINK), too but no confirmation possible.

Don’t swap all of your ETH. You need to leave a sufficient amount so you can pay for the network fees.

1 Like

Thanks @iamdeadlyz I thought the fee would be deducted automatically.

1 Like

I had the same problem - thanks to this thread I figured it out.
The app should really make this clear as I was floundering for a fair while.


I have relayed this bug yesterday and I can confirm that the dev team plans to fix this in the next build. Glad to know that this thread helped you, cheers!

1 Like

A post was split to a new topic: Stuck in a loop while swapping. Asks me to select “Currency to Get” - > “Currency To Pay”

A post was split to a new topic: Can’t proceed in swapping with Pancakeswap