Trying to swap using Pancakeswap, but got stuck during the approval (loading animation)

I’m just gonna throw my question in here since i’m not allowed to create a post (yet).

Since yesterday i’ve been trying to swap using pancakeswap. However upon approvinfg it seems to be stuck. (Spinning circle)

I can’t do anything with my balance, what can i do?!

Disconnecting the wallet etc is not workint

3 Likes

Hi @Potatoridge,

To better assist, please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)
  2. Smart Chain wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here)
  3. Further details about your issue (please explain what you were trying to do)
  4. Screenshots of the wallet (including errors or missing balance)
1 Like

i am trying to convert my SPE to bnb

Try a full reinstall of the app.
Make sure you have a backup before you proceed.

Uninstall and then reinstall your app.
Follow this guide to restore your wallet.

1 Like

You are amazing. It works again many thanks!!

Not quite sure what the issue was though

I have the same problem as you, I tried to disconnect the wallet and it also didn’t help

@ferero18, read my previous response and check if it will fix the issue or not ^ (about re-installing the app)

Hi, thanks for sharing the fix. Re-installing the app has helped thank you!

Mine worked eventually guys, via Trust Wallet too. This is all on the PancakeSwap side I think, their Reddit has lots of complaints, it’s probably just an overload. Maybe try at more unsociable times, that might help.

Unfortunately removing the wallet doesn’t work to load it again. Even with the new wallet and phone, the situation is the same, which doesn’t work. Also, transferring the coin to another account will not work. We are now connected and this is very worrying and sad. Our losses are increasing due to this situation!

I cant say about pending transactions, you can try it but to the issue where it gets stuck on approval, where the approval icon keeps circling and never ends…

I got stuck with approving while converting safemars into bnb, on pancake V2.

after looking at forums and Google for a fix (found nothing). I went to pancake, switched to V1, got to the exchange, added safemars token via its contract address and the approval was already done, it allowed me to swap directly into bnb…

Might work for you guys too. give it a try