Unable to add custom network Canto to trust wallet ver 8.14

Hi Team - I’m unable to add custom network Canto to trust wallet ver 8.14. I get node connection error. Not sure what it means. Any assistance is appreciated.

1 Like

@razer1 You should select the CANTO option under Chainlist.

1 Like

I did that, under Chainlist → Canto, but nothing gets populated into the network fields. It’s just empty. The n/w fields gets populated for most other networks under Chainlist. Its empty for CANTO and few other networks (like ROOTSTOCK) under Chainlist.

On another topic related to adding new networks such as re.al network , trust wallet simply adds the network and does not update the gas token quantity, it remains 0. When trying to approve transaction, i get error such as below. Could not upload pic as reply to post does not allow media upload. What is the issue here.

CustomChain Custom(cointype=Ethereum,chainID=111188,coinID=reeth,feeRate=0.0,denom=,prefix=) not found in nodeRepository. Perhaps you need to call setNode first.

@razer1 Can you uninstall and install your app again.
I tried adding the CANTO network on my device and it worked.

1 Like

Hi, I’ve uninstalled and reinstalled the app. However, Canto network could not be added through the chainlist method explained earlier. I still get no data populated in the network fields.

Manually adding the network again by typing it to the network fields did not now show the node connection error and the network was added. However, this result was short lived as the Canto token did not update the token quantity and just remained 0.

I did install the app in another phone and the result was the same. The trust wallet app installed and reinstalled is android version 8.14

@razer1 I’d suggest you submit a ticket to the Customer support team