Unable to send BTC from my Trust wallet

For some reason I can not send any BTC from my Trust wallet. When sending (both, from browser extension and app) an error pops out: “please consider decreasing sending amount or topping up the balance”. I have tried from several devices, browsers, in different time, etc. As of now I have 0.00163 BTC (~100$) which should be sufficient for sending, as its surely exceeds transaction fees. But each time it is the same.

Note: About a month ago I tried to withdraw some amount (~70$) from trust wallet to binance wallet (hash: afa8eb4932866e4794b2f5fbf9e7e1cdcf49ce665b9070a6a4664610160fe738), but at the end for some reason only ~0.00005 BTC (~3.4$) went through instead of the full amount. This reduced my wallet amount by the amount sent (same ~0.00005 BTC), but overall nothing serious. After this happened, I can not do anything with my BTCs.

Now I tried to increase the amount up to 100$ (from 70$ adding up 30$) but still the same. When trying to send lower amounts, though, it shows that I can send something about 30$. Why it is like that?

Could it be that something wrong with indication of my available funds? If so, what happened to my transaction and why instead of 70$ that were sent, only 3.4$ were received?

3 Likes

@mggarn I suggest you submit a ticket to the Customer support team through your Trust app or at support.trustwallet.com
To reduce response times from customer support, please include the following info in the ticket:

App version, device model, wallet address, TX hash (if available), and the blockchain + assets you’re experiencing the issue with, and any relevant screenshots or videos to duplicate the error.

2 Likes

Additionally, attaching my BTC wallet:
bc1q29u0skhpugfjt9l04h62zeaywmnl0g2ewclp2r

In mempool as well it indicates ‎0,00163469BTC on my balance.

1 Like

I tried that, each time after I fill the support form it sends me to login page, where I don’t have any login or password. Login & password from community.trustwallet is not applicable there.

2 Likes

@mggarn You do not need a login to submit a ticket.
Just hit the back button then submit the ticket again, if that doesn’t work then remove any attachments if you added any and submit the ticket.

4 Likes