Unable to Swap Kishu Inu

Good morning. Thank you for everyone helping me with my last post I appreciate it. I have another problem. I have approved my Kishu Inu for swapping on Oct 22, for swapping after I did I spent till Oct 25 with no success of swapping to do so. So on Oct, 25th I tried to revoke the approval of the Kishu Inu, and did that successfully. Now when I try to approve my Kishu Inu It fails to do. I am at a lost is there any way to properly approve my token and to swap for ETH? Many thanks again.

:warning: Balance is now displaying well.

ETH nodes were temporarily out of sync. There were issues with seeing and sending/receiving ETH and ERC20 tokens.

Issue has been fixed.

Thank you and sorry for the inconveniences

If you still can’t see your tokens, re-import your wallet: How to Re-Import your Wallet


So, I approved my Kishu again and payed my gas fees again and I still cannot properly swap my tokens. I keep getting this error message, that says “Execution reverted return amount is not enough” it’s frustrating I’m paying gas fees that are non refundable and still being denied.


I too have same problem… swapped kishu with ethereum and paid fee $50 AUD … but the transaction are getting updated to reflect correct amount of coins…

request trustwallet to please resolve…

Hello @satishvuppala @necrowyn To better assist, please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)

  2. Crypto wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here. Also copy and paste it in plain text)

  3. Transaction hash or link (if you have any, please copy and paste)

  4. Further details about your issue (please explain what you were trying to do)

  5. Screenshots of the wallet (including errors or missing balance)

  1. Swap approved transaction hash 0x05c18b14555f83153507dfc3be98350b86926f2b61b0110f44e81e15e7fc954b
  2. I am trying to swap KISHU with Ethereum. Initially it asked me to approve and upon approve a gas fee was charged. After approval is processed, i am unable to swap KISHU with Ethereum. Please refer to point no.5 for the error details.

Can you try swapping a lesser amount than the max of the Kishu Inu you have and see if it works.

Hi Alan,

I have exactly the same problem, I initiated a swap from Kishu to ETH, I see a message saying it was successful but the transaction is apparently waiting for approval, how do I approve it?

My wallet still shows kishu in my account but no value?

I initiated the swap 10 hours ago, please help?


I swapped Kishu for ETH says it is completed but no Kishu was deducted nor was ETH added? What happened

Yeah same here. I used the dextool to swap kishu to eth, everything is completed per explorer but nothing was updated.

just out of interest, has anyone tried viewing their transaction on ether IO?

if so, is there a message there saying awaiting approval?

has anyone tried swapping or trading their kishu after the failed transaction? mine seems to be locked up but then again I’m quite new to crypto and still trying to get my head around everything…

@alex33, @Bsny79 , @Tnizzysan
When swapping tokens for the first time, you have to approve it first to be spendable. And, that is what you did just now.

Since you are done approving the token, you need to enter the amount that you want to exchange then press the swap button.

All in all, you will confirm two transactions: approve and swap

NB: Both token approval and swapping transactions needs gas fees.

Hi Jenny,
Thanks for the reply.

I did approve the transaction when asked to, just in case I didn’t, how do I check?

And in the case I didn’t approve twice, how do I go back and approve?

And if I did approve twice, why is the transaction showing as successful when my balance of kishu remains the same?

Sorry for all the questions but the app is not very user friendly, at least not to novices like me.

Kind regards

I followed everything to the tee. I approved and it was swapped. I looked at the explorer on ethscan and it shows me the swap was successful. Tried reimporting

Tried reimporting my wallet and it still showsni have kishu and no eth but when I try to redo it, it says return amount is greater or whatever.

I had mine approved this morning, cost me 65usd in etherium, still cant swap my kishu inu to etherium. I just re-imported my wallet and still cant swap, keep getting the same message “execution reverted: Return amount is not enough”. I am new to all this, just tried to swap Kishu Inu to Etherium, followed all the prompts that came up and no joy, please help Im loosing money as we speak.

Clearly there is an issue with Trust Wallet, while I appreciate how busy the support team must be with so many users, I do not expect immediate replies or solutions but it is discouraging to see what appears to be an unreported bug in the wallet that displays an obviously failed transaction as successful.

While meticulously following TW guidance as a first time user I have probably lost over $200 in gas fees while trying or retrying the transaction, have scoured the web for an answer without success and perhaps missed the opportunity to cash out while in profit. Issues like this spread very quickly across crypto communities.

Your explanation helped give a better understanding of the process but did not address the issue or offer advice on what to do next to resolve the issue, are the transactions valid? do we as users need to give further approval? do the rates at the time of transaction still apply?

Please acknowledge (with urgency) that there is a serious flaw in TW to end the frustration of users who have been affected and to prevent any new users from suffering the same loss and frustration, OR provide a step by step guide on how to successfully swap on TW.

A timely reply would be appreciated.


1 Like

Also, why is it impossible to connect my iOS trust wallet to web3?


@alex33 , @bopo , @Tnizzysan
Please do provide your receiving address, the swap should have already took place

Eth wallet and you can see the transaction