Unable to Swap Token, unable to Approve

Hello All, starting to buy new coins.

Have read the Faq and help pages and unable to find the answer. Other coins show the “Swap” icon, but this token does not.

Would someone review and explain why?
I think this is more a generic questions, so I don’t have to paste my wallet or transaction. The coin is currently on TW and I used Uniswap connected to TW to swap Matic to SMT.

Specifically this one:

TokenSwarm Markets (SMT)


1 Like

@dalaberas No all token pairs are supported in the Trust app, some you have to swap through a dApp e.g Uniswap like you mentioned.


Thank you @Tobi. Do you know what is the technical process to approve?
If you can point me to a web page or link that could work too.

1 Like

@dalaberas I’m not sure I understand what you mean by that.

What process does TW follows to approve a token pair?
What are the requirements?

1 Like

Hi, I tried swapping HCAT to BnB on pancake swap, it seems the swap is complete but have not received the tokens/funds. It has a tag on APPROVE, I even tried adding the token manually and restoring the wallet but have not received them yet. NOTE that the transaction is marked as complete and wants me to approve, on BscScan, it is seems approved however.

Here is the transaction harsh:


Kindly advise accordingly.

@KingBjorn When swapping tokens for the first time, you must approve it first to be spendable. That is what you did.
Since you are done approving the token, you need to enter the amount that you want to exchange, then press the swap button.
All in all, you will confirm two transactions: approve and swap.