Unable to unstake solana

Hi, i m tryng to unstake Solana. Got 0.8 sol avalaible so no gas fee problem.
I did unstake 4 days ago. Trasanction is still open and no way to obtain my tokens back

This is my adress

On Sol Scan it seems ok but transaction is suspended

Thanks in advance for help


@fringekollective Please submit a support ticket from your Trust wallet app.

Settings → Support
or at support.trustwallet.com

To reduce response times from customer support, please include the following info in the ticket:

App version, device model, wallet address, TX hash (if available), and the blockchain + assets you’re experiencing the issue with, and any relevant screenshots or videos to duplicate the error.

Impossible to open a ticket. It just open a useless chat gpt chat that gives no help


@fringekollective Tap the Submit ticket on the upper right corner to submit a ticket.

1 Like

I have a similar issue.
On marche 8th I unstaked my SOL and according to Solscan that seemed succesful.

However my balance did not get updated, even after several epoch rounds. Beginning of this week I saw that in the staking section there were claimable reward, being the amount of SOL that I staked. Therefore, I tried to claim the reward at the beginning of the week and yesterday again. Now I have two similar transaction pending with one epoch round ended and the seconde one ending tomorrow.

When I look at the pending transaction on Solscan they show the message “no data”.
In the meantime my SOL is locked.

I have send support a ticket yesterday but after submitting I got redirected to a support login page where I don’t have an account for. And on that page you aren’t able to create an account either. Now I’m not sure if my ticket is submitted correctly. I haven’t received a confirmation mail as well.

1 Like

App version 8.11
Wallet address:

@Pisklink Please submit a support ticket through your Trust wallet app or at support.trustwallet.com.
Please ensure you provide adequate information for the support so the issue can be replicated.

Tobi thanks for your swift response.
However please see the last alinea of my post regarding me sending a support ticket.

@Pisklink Please ignore the login page, just hit the back button and resubmit the ticket.

I found a way on my own. I imported wallet in desktop version and repeated unstake. This time this seems works and token are on the way

I keep on getting to the login page after submitting the support ticket.
Shouldn’t I get a confirmation mail as well?

I see this response in multiple threads across this forum.
Can’t you make a pinned post on the forum to explain the problem and provide a possible solution?

Based on your message and the fact that I don’t know who you are, I’m inclined to think it might be spam.
Besides that I don’t have Telegram and now I’m forced to get it.

Like I said I have seen your post in multiple threads and therefore is would be logical to have a sticky thread with the explanation and solution presented.

@Pisklink Please that’s an impersonator, I would not initiate a chat elsewhere.
Like I said earlier, the best way to get support is to submit a ticket and wait for a response.
If you are still having issues submitting a ticket, remove any attachments from the ticket you’re trying to submit and resubmit.
Here’s the link again:

Thanks, I haven’t tried that yet an I will give that a try as well. Hopefully that will work.

But at the end, no way to withdraw Sol via trust wallet. Same error as to unstake. Resolved using importing seed in another wallet to withdraw ( in my case crypto.com defi wallet). Sorry but TW is a mess full of bugs