Unable to vote via the Dapp

Hello,
i have noticed that it is impossible to vote via the Dapp in Trust.
I’ve tried to vote for Pancakeswap, Uniswap, trustgovernance, it was the same error message oops wrong timestamp although i have some tokens before the snapshot.
But when i use the browser like chrome, i can vote via wallet connect.
I’ve constated also that via wallet connect, i have been connected directly to the BSC blockchain and can only vote using my BEP20 TWT tokens, do we have to swap our BEP2 TWT tokens to BEP20?

3 Likes

Hello @marie,

To better assist, please provide us the following information:

  1. Trust Wallet app version (go to settings and press “About”)
  2. Crypto address
  3. Screenshots of the wallet (including errors, if any)
1 Like

Hello @iamdeadlyz,
as requested you can the information below:

  1. 1.22.4
    2: 0x26b56CE0cf64CCE067F0CFb45303bA71F46f3078

Thanks for providing the requested information.

Please sync your time by following this guide: https://www.androidcentral.com/why-wont-my-phone-keep-right-time

Let me know if that works or not.

1 Like

Thanks but i use it already, my phone is on GMT + 0 time.

Please use this link and try again: https://governance.trustwallet.com/#/trustwallet/proposal/QmRKzJVqN8m8WpUSGun2bnBdLWSNNtj2xVGJsWUMb3jCZJ

1 Like

It is the same error “Oops wrong timestamp”

Changes are now applied. Please try again @marie

1 Like

It is the same thing “wrong timestamp”. I can only vote via “wallet connect”

Try reinstalling Trust Wallet app and importing the wallet before trying again.

Hello,
i’ve updated the app this morning and the vote has passed thanks!

1 Like

Glad to know that! Thanks for letting us know, Marie!