Unable unstake bnb

Update didn’t help. Still same problem.

  1. app version 7.17.5
  2. bnb14qkc7cq37gn9lhcxkqx8xahjm9zc59p00gr42h
  3. last transaction with redelegatio to Legend III validator: BNB Beacon Chain Explorer
  4. trying to unstake my BNB from validator Legend III I get an error message saying “Transaction error, no delegation for this (address, validator) pair - Code: 400.”
    Same error if I try to change validator.
  5. I get an error
1 Like

Any solution guys? Last update didn’t help. Version 7.19.2 give same error :sob:

1 Like

Admins? Noone can help?

There is a transaction with redelagation to Legend III delegator that sais:

"delegatorAddress": "bnb14qkc7cq37gn9lhcxkqx8xahjm9zc59p00gr42h",
 "srcValidatorAddress": "bva1z0g0cg8dkgczr6r8t6khva3srn5mwj8w5tlu7h",
 "dstValidatorAddress": "bva1we4frydjkyejdzp506gzpljaqpqu5fs0flu60p",

now when I try to unstake BNB I get written:

From: “bnb14qkc7cq37gn9lhcxkqx8xahjm9zc59p00gr42h”
Validator: “bva1z0g0cg8dkgczr6r8t6khva3srn5mwj8w5tlu7h”
Memo: Stake via Trust Wallet

When I click on confirm I get an error “no delegation for this (address, validator) pair”.
How can it be possible? I even continue to get stake rewards.

Hello @Eluzh what is your Trust Wallet version right now ? are you on the Latest Version ? any screenshot could help us to solve your issue .

Hey @k.amon
Thanks for reply. Always updated to latest version. Now its 7.21.1
Screenshot is already posted in first topic. Nothing changed. Get always the same error.

I cant add New media in post, I get an error

go to your Settings in Trust Wallet NODE changing the BNB node from automatic to manual could help you.