Unstaking Tezos crashes wallet

Unable to unstake Tezos. Once unstake is pressed the wallet closes. This is on IOS

2 Likes

Please make sure you update to the most recent version for iOS.
You can get the links here:
https://community.trustwallet.com/t/where-to-download-trust-wallet/693/4

If you still have issues, please provide the following:

  1. Current Trust Wallet version, get this from Settings then About.
  2. Your Tezos address.
  3. Validator/Baker you selected
  4. Screenshot of error messages (if you have any)
2 Likes

I actually never selected a baker and staked my Tezos. I transferred them in and went to stake but I got an error message that disappeared but it says that my Tezos are staked.

tz1cip3SzDVvGAEmdUcZV9MWFEmjsSgS5zMJ

2 Likes

1 Like

Thanks for providing the information.
I checked the status of your XTZ wallet

You are right that it is not yet staked.
Can see some staking command was successful.

2 Likes

Nope. Restarted. Created another wallet. Transferred to new wallet and then back. Still not working. I even sign the transaction and pay the fees but it never stakes.

1 Like

Seems the Tezos explorer is just showing delayed response.
Saw the following transactions:

For Tezos, you do not need to do Unstake command, if you plan to just move to another baker.
You can just do a Stake command and choose a new Baker.

1 Like

Ok I guess I’m good even though I’m getting an error. Block explorer says I’m delegated.

3 Likes

I have the same result when staking Tezos. I get the error message and under my Tezos info it says my full amount is available and the full amount is staked which seems wrong. Is it supposed to show rewards etc like when you stake Cosmos? I’ve tried to stake the Tezos several times but get the error message every time.

Learn more about staking Tezos here:
https://community.trustwallet.com/t/how-to-stake-tezos-xtz-on-trust-wallet/48/2
Can you provide more details about the error.

  1. Trust Wallet app version
  2. Crypto address
  3. Transaction ID (if you have any)
  4. Screenshots of the wallet (errors, if any)
1 Like