Wallet connect / confirm problem with uniswap

I used the built in Dapps browser in the newest Android app, and I selected uniswap to try and buy myself an erc20 coin… I think the browser was set for BSC, though. Once I was to confirm I got some notification in the app but it disappeared, I can’t find anything anywhere, and if I go into DApps again and select uniswap, the “connect wallet splash” will come up, but then it will still have “connect wallet” button in the app. If I exit and come back, I don’t even get the splash back… but I can get that back by clearing the cache of DApps browser. Still doesn’t work, though. Pancakeswap connects to BSC fine, it seems… though I haven’t tried a transaction there yet. So back to uniswap… do I have some kind of unconfirmed ERC20 swap floating around BSC that messes everything up? How do cancel it?
If I went to uniswap on my desktop and did “connect wallet” with camera, that seems to work, and I got the confirmation.

What’s wrong with my wallet? Tried clearing cache, rebooting phone… anything but reinstalling the app, which I’m scared to do that… in case I screw up and lose all my coins.

To better assist, please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)

  2. Crypto wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here)

  3. Transaction hash or link (if you have any, please copy and paste)

  4. Screenshots of the wallet (including errors or missing balance)


The forum doesn’t allow me to post screenshots.

Android app 2.11

ETH: 0x98872d38eEFB12AA8E7Bc16053C732bBC9F124fc

BNB: bnb12x74a2y4y7n03dwwx2ru2np69tp3pnputsfy6f

No coins missing, and I don’t have any data on the possible failed transaction.

Can you provide your transaction hash and screenshot of the failed transaction.

No, like I said, I don’t really have any more information… the transaction is no where to be found, nor the notifications. I have no successful transactions from this wallet, after, though… possibly more than one failed one. The wallet doesn’t really work with UniSwap since then, so…Just wont connect in Dapps browser.

Ok, so… I couldn’t do anything with uniswap. But BSC seemed to connect, so I actually performed a pancakeswap trade, and that worked flawlessly. That seems to have triggered something, also, because now I can go into uniswap and it connects the wallet. I guess I managed to solve my own problem!
Figured I’d share, if someone had the same problem!

Thanks! :slight_smile: