WalletConnect Signatures Won't Approve

Every DApp I connect to via WalletConnect with my iPhone connects fine, and when the DApp asks for approval, I get a signature request on my iPhone. But when I try to approve the request, the DApp does not receive the approval. It’s as if the signature was not valid or did not send back to the DApp correctly. I just get spinning wheels in the DApps waiting for signature approval.

I have an iPhone and updated to the latest version (15.1). My Trust Wallet version is also the latest version (6.11). I can connect to multiple different DApps such as SnapShot and Collab.Land. I have connected on my iPhone, and also on multiple different desktop browsers (I have cleared their history/cache too). I have gotten responses about “clearing my DApp Cache” in the iPhone app, but my app does not show that option. Preferences only shows “Currency” and “App Language.”

I’m fairly confident the issues are not with the DApps, but rather with my app not sending the signature approval back to the DApps correctly.

2 Likes

WOW! 17 hours since you posted your problem and 2 hours since I seconded the same issue and Customer support haven’t even approved my reply to you and worse haven’t felt with your issue!
If a person can’t complete the one simple thing I came here for the wallet is useless. These guys are getting rich off of all the little gouges here and there just theu process and still no joy.
Very very very frustrating!

I’ve had the exact same problem. Makes App useless for this kind of transaction. Any word from tech support on this yet?
This kind of garbage is what will hold back adoption by the general public. It is like pulling off a Mars shot to get a simple transaction actually completed.

So I actually found a workaround myself, which is to turn off transaction approvals for signatures. Then they don’t need to receive an approved signature. Still an issue with those who want to keep signature approvals for all transactions though.

Hello guys, I have the exact same problem. I’m facing it already several months.

Whenever I try to connect to dApp using the WalletConnect and Trust Wallet, the Trust Wallet doesn’t display “signature request” so the dApp just keeps pending and nothing happens. You can try that e.g. on coinbrain but the result is exactly the same on every other dApp I tried.

I tried several different wallets and all of them work fine. The issue must be on your side. So please check that properly and try to fix it! Without that, your wallet is kinda useless… Thank you!

@megamind It may be your device, did you try checking if your app is up to date?
Delete the app and reinstall BUT backup your wallet first.
You can also try accessing the dApp on a web browser then connecting your Trust wallet via the wallet connect option if that works.