WETH showing in wallet but zero USD balance

Hi! Please help! I swapped 0.267 ETH to 0.267 WETH (Base) yesterday. The 0.267 WETH are showing in my Trust Wallet but the USD value is showing as zero. I tried deleting the App and re-installing.
Trust Wallet App version 11.2(967)
Device – iPhone 11 iOS 17.3.1.
Wallet address: 0x7b542c0d337753e5df4272a036698c346c150a0e
TX hash: 0x1d9e5192ece282af7a5922ee0abb1da09f578e946d34c0002ac4a70758e3247b
Thanks :slight_smile:

@Cnb Can you please submit a ticket here support.trustwallet.com regarding this.
Alternatively you can always track these token prices on coinmarketcap.

Hi Tobi. Thanks for your reply. I logged a case but then it directs me to a page saying ‘I must log in to use this service’, and then it won’t allow me to log in…. So unfortunately I appear stuck…. I can check the token price ok, but I can’t do anything with my WETH (I assume because the value is showing USD 0…). Any more help gratefully received!

@Cnb You can tap the upper right corner on that page with the chatbot to submit a ticket.

Hi Tobi. I submitted a ticket, passed verification but then a ‘log in to the support portal’ screen pops up and says ‘you must be logged in the access this page’…. Weird, because of course I am already logged in. I enter my log in details again and it says ‘the email and password you entered does not match’, even though it is correct. So it seems my ticket isn’t getting submitted…. Any other way to contact someone who can help please?

@Cnb You do not need a login to submit a ticket.
If you see a submit ticket button, just hit the back button on your browser and resubmit.

Hi Tobi. Thanks for replying again. I’ve solved the issue by sending the WETH to a MetaMask wallet, which is allowing me to swap it, etc. Thanks :slight_smile:

1 Like