When I import wallet, tokens aren't showing. Recovery phrase is correct

I tried transferring my VET and VTHO from Coinbase to the Coinbase wallet. That didn’t work, found out from Coinbase afterwards that their wallet doesn’t support it and said I need to import my wallet into another one to access it. From VeChain stats it shows the tokens still there.

I imported my wallet with the recovery phase to Trust Wallet, but my tokens aren’t showing. How do I recover them? I’ve tried importing, re-importing and scouring the site but haven’t found the solution yet. When I import them to Trust via VeChain network, and toggle VET and VTHO on, they show a zero balance.

  1. Trust Wallet app version: 8.5.8
  2. Crypto wallet address: 0x980CF002BCf352A90D2fc69285FE14228bA4DFC0
  3. Transaction hash or link: (3 total transactions)
    0x980CF002BCf352A90D2fc69285FE14228bA4DFC0 - VeChain account
  4. Further details about your issue: Trying to import wallet to Trust Wallet. Wallet imports it shows VET and VTHO but with a 0 balance.
1 Like

@mavrik2747 Importing your wallet as a VET wallet should display your tokens except if you have sent to your BEP20 address on the native VET network.
Can you confirm which?