XRP balance not showing, but transaction on network looks good

Hello, I’m also experiencing the same issue of not being able to see my account balance.


Receiving wallet address: rMqJwcXAcPg1kXTSVTBk3i7yANuHF2T8xo

Transaction: 139c5e910d8e4b7595fecaa9289da1592010cc81af096dba0927e8bb7060a708

I was attempting to transfer my XRP balance from Kucoin to Trustwallet.

I have tried to update the app and reimport my wallet with the security phrase.

Balance still shows 0 after the network has claimed success for my transaction.

Any help would be appreciated and thank you in advance

1 Like

Hello @Grinix where are you located? Can you try to use VPN and refresh your wallet (try to connect to different locations and refresh). If problem persists let us know.

1 Like

I’m located in USA. Connecting to a VPN worked thank you. I didn’t have to connect outside of the US on the VPN which is interesting… But it worked.

Great! Glad to know that. If you have further inquiries, feel free to message us. Stay SAFU!

1 Like