Bitcoins disappeared after swapping ETH BEP2 for ETH BEP20

Dear support and community,

I initially purchased BNB, which I successfully swapped for ETH BEP2.
However, within the app or I don’t see any transaction. After this first successful swap I tried swapping ETH BEP2 for ETHBEP20 within the app, but my funds disappeared. There is no transaction history and I can neither find a trace on

According to the FAQ I tried deleting and re-importing the wallet, which didn’t help.
So, where are my funds? They can’t just disappear without a trace?!
Using iOS App Version 6.1.1 (6111) right now, but the issue occured 2 days ago with a previous app version.

I can send my public address via PM.

Thanks in advance,

Hello @jlx
If you have swapped your tokens for BEP20 ETH then your tokens will be on the smartchain network.
Each networks have their respective explorers

  1. - for ERC20 tokens
  2. - for BEP20 tokens
  3. - for BEP2 tokens

Hello Jenny,

thanks for the quick reply.
I managed to find the swap on bscscan:
transaction hash: 0x36c56237d49d2afa7933f7b46d50250cda2077619aa9526d0fdd9c59b54a928a

How can I access these bitcoins via the app? Why are they not shown?

1 Like

Hello @jlx,
What do you mean ? Can you provide your receiving address?

My receiving address should be:

Why is this transaction not listed within the app?

Hello @jlx
You have the Binance pegged ETH, please add as a custom token

I already added Binance-Peg Ethereum from within the app. I could find an preexisting entry in “manage” using the search function and enabled it. But when I view “Binance-Peg Ethereum” (BEP20) from within the app, nothing is shown (no transaction, 0 ETH).

I also tried adding a custom token in case that it makes a difference, but it doesn’t. Why are my Binance-Peg Ethereum (BEP20) not shown in the app? (as mentioned, I already deleted and reimported my wallet)

So, how do I resolve this? How may I recover my Binance-Peg Ethereum within the app?

Hello @jlx
Here is your address on the explorer showing your Binance-pegged ETH

I know - I’ve confirmed this earlier. My problem is that these bitcoins are not shown within my trust wallet app. Thus, I cannot swap/exchange them via Trust Wallet. How do I get them to be shown?

  1. Delete and reimport of my wallet doesn’t help
  2. Of course, I imported the Binance-pegged ETH token manually in the app.