Bought crypto from Simplex, then my crypto never shows up. It’s been an hour and nothing

This wallet is complete crap. I purchased BNB using TrustWallet. It took me at least 30 minutes to go through the 90,000 requirements required by the “integrated” Simplex app, then my crypto never shows up. It’s been an hour and nothing. Then I login to this site to open a ticket, and I can’t open a ticket, because I have to build “Trust”. Once I dispute this transaction with my credit card company, I’m going to spend a year sharing my crappy experience and letting every know not to use the POS.


Hi @bobbyrolls,

Please be informed that Simplex is a third-party crypto provider. You have to reach out to them directly so they can investigate your issue:

Having the same issue. After 48 hours of waiting and no response from simplex, I haven’t received by BNB crypto yet, my walled ID is 0xA197f215ee82f59da08d754C20868181098E0C78

Same here, bought $50 worth of LTC 3 days ago via Simplex. Waited the 48hrs as suggested by Simplex before emailing support. Day 4 still no response, nor have I received the coin. Checked the blockchain each day and still no transactions on the wallet from them. They even sent me an email asking me to verify the transaction and that I received the crypto. What a joke…surprised Trust Wallet even allowed this 3rd Party Provider…makes me second guess using this app. Stick with the big exchanges, they may be expensive but at least they can be held accountable for their actions/inactions. Luckily $50 won’t make or break me, but it wasn’t exactly a cheap lesson on getting scammed either. A quick Google search after the fact pointed to Simplex being a shady service. That’s what I get for trusting an unknown app and an even more unknown 3rd party provider. Shame on me :confused:

Did you recieve a confirmation of transaction? Cause I didn’t recieve anything after the transfer was made to follow the transfer.

Everyone please help me When I open my Trust wallet I can see that there are Ethereum in my Smart Chain Wallet but I am unable to do anything with them as my wallet is a ‘watch only’ wallet evidently. I don’t know how it became a ‘watch only’ wallet as I didn’t knowingly down load it as one, I thought that I would get just an ordinary Trust Wallet when I down loaded it from the App Store. Either way I’m now unable to do anything with these tokens.
I tried send or buy it pop up watch only Wallet,can someone help me Please…

Hello @JagmeetSingh watch only wallet means you imported wallet address instead of wallet recovery phrase. Import the wallet recovery phrase to have full access of your wallet. Here’s a guide on how to import: How to Import a Wallet & Our Top Tips To Do So Securely