Can‘t sign KAVA and HARD transactions anymore

Hi there

Since today, I can‘t sign my KAVA and HARD transactions anymore. I can connect the wallet to the app, I can initiate the transaction (mint USDX, claim KAVA or claim HARD) but once I swap back to the wallet to confirm a transaction, it just doesn‘t show up so I can‘t sign anything. Is this a general problem with trust wallet right now or what is happening? Been able to mint, claim, etc just fine the last few month. Kinda sucks to having passed the HARD-claim-date because of this…

I‘m using the latest iOS version btw.

Thanks for the help

1 Like

Hi @mimu,

To better assist, please provide us the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)
  2. KAVA wallet address
  3. Are you using WalletConnect?
  4. Link of the DApp that you are using
  5. Screenshots of the wallet (including errors, if any)

I am having the exact same problem. The confirmation message never appears on trust wallet


Version is 5.13 ( 5135)
Address is
I am using wallet connect and the dapp is kava . io ( it won’t let me include links)

1 Like

To clarify, is this the link?

  1. 5.13 (5135)
  2. kava:
    nmb smart chain:
  3. yes
  4. and

the adress showing in the screenshot is my smart chain adress. i‘m not sure this always has been the case.

I‘m pretty sure this all has to do with the newest update to the wallet that I‘ve installed on 12.02. via app store, as before, everything worked.

Please fix this as soon as possible! Not only will my rewards expire, I‘m also not able to mint/repay/move ANY of my funds in KAVA/HARD. If one of the coins falls and I can‘t repay, I will be liquidated!

As I somehow can‘t send a support ticket and reddit won‘t supply, you‘re my only hope…

1 Like

Thank you for providing the requested details. This issue is now relayed to the dev team. Will get back to you if I hear any updates.

1 Like

I am having the same issue here I am using iOS as well and have all the latest. Same issue as OP. Please fix!

1 Like

I am in exactly the same situation! please help me! !!

1 Like

Similar issue here! Pls. help!

1 Like

any updates? i still cant access any of my coins in the kava/hard apps because of this. and it seems like i‘m not the only one!
fix asap please!

1 Like

i still can’t sighning = can’t access to my funds.

1 Like

Can anyone sign for anything outside of KAVA?

@S8M6S @kazu1 @aweSam @mimu

Please try to use a laptop or desktop pc then try to connect with WalletConnect. Let me know if it works or not.

I could do it by desktop!!thanks!!
when do you think I can use mobile to sighning??


You’re welcome~

The issue could be on the DApp’s end. It may not work well when used with a mobile browser.

It has used perfectly since I started using kava/hard and only stopped working after the last Trustwallet-update on the 12.2. - the problem is most definitely on your end, seemingly only on iOS.

Please fix this!


maybe so.but I asked the kava telegram.they said team are trying to solve it.
so it’s maby kava ploblem.

1 Like

Using desktop has worked for Kazu1, did you give it a try?

1 Like

A post was split to a new topic: I’m unable to stake or unstake my KAVA