Can‘t sign KAVA and HARD transactions anymore

I tried the desktop pc and got this error: Error during Broadcasting

unauthorized: signature verification failed; verify correct account sequence and chain-id

1 Like

Please update your app to the latest version (5.14) then try again.

i already updated to latest version 5.14(5143). I also have issue sending KAVA in my trust wallet same error I’m getting…

1 Like

All type of transactions related to KAVA same error pop up when approving it…

1 Like

Noted. The dev team will release a fix on the next builds. Please keep an eye out for updates.

thank you. keep us posted.

1 Like

I am having the exact same problem. Cannot increase my borrowing or repay USDX. Trust wallet shows 0 USDX balance even though I clearly have a balance repayable of about $672 USD.
Please help as at the moment my funds are stuck with no way to access.

BTW - I have tried ot attach image & links, but not able to do so in this post. How can others attach?

1 Like

Hello @Ginantonix,

Please try to attach image and links again.

Hi @iamdeadlyz,
Trying images & links again:

When I try to increase borrowing, I have received a fail message as follows: Interchain Explorer by Cosmostation

Then when I tried repaying some of the debt, I received the following fail message: Interchain Explorer by Cosmostation

1 Like

Upon checking you indeed don’t have any USDX to repay. That’s why the transaction fails.

Interchain Explorer by Cosmostation

sorry @iamdeadlyz,
I am a bit of a noob, so may be misunderstanding how the wallet works. After minting USDX I transferred the USDX to Hard Protocol. So does that mean I have to withdrawal from Hard Protocol back to Kava in order to adjust my borrowing?

Hi @iamdeadlyz,
I managed to transfer back from Hard Protocol and repaid all of my debt to test.
But now when I try to borrow USDX again (to just under safe limit) based on locking my BNB, I get a new error message:

This worked fine for my initial borrowing, but now doesn’t seem to work.

This has not solved the problem for me. I updated the wallet, that didn’t work so I deleted and redownloaded the wallet adding my seed phrase again. And still no message to sign transaction ever comes up on trust wallet. This is over a week now I haven’t been able to access my funds…

1 Like

same here - fix this please!


@Ginantonix, try to lower the USDX that you are going to borrow. Decrease by at least 5 USDX.

@Tyler165 @mimu, as stated earlier, the dev team will release a fix on the next builds. Please wait for it. Thank you for your patience.

They released an update today. I assumed that was it, it said update for cosmos chain…

You may give it a try.

still not working and the kava rewards will expire in a week if i don‘t claim them…

1 Like

I see. In that case, please wait for the dev team of Trust Wallet to release a fix. They are working on it right now,

That’s what I’m saying. They released an update yesterday saying it had fixed problem with cosmos chain. It didn’t work.

1 Like