Can’t unstake BNB

I have staked 1 bnb on trust wallet a couple months ago, i don’t remember the validator, it still shows in my wallet balance as ‘1 bnb staking’ plus the rewards. But when I go to the staking page it says 0 bnb staking, the validator had disappeared, I have no option to redelegate, and if I hit unstake it says it is unavailable. Iv seen this question asked in the comments of another sub but now answers, it seems like the validator has disappeared.


Hello please read this:

I don’t see a redelegate option. I can only see stake and unstake. I have a little over 1 bnb staked and I can’t unstake it. Any other thoughts on what’s happening here?

I don’t have a stake details option, the staking page is showing 0 and the only other button are stake and unstake, if I press unstake it says unavailable, there is no option or way of redelegating. This is the second time Iv come to unstake and this time is appears to of disappeared.

Hello @Edali @Nufcdurham To better assist, please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)

  2. Crypto wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here. Also copy and paste it in plain text)

  3. Transaction hash or link (if you have any, please copy and paste)

  4. Further details about your issue (please explain what you were trying to do)

  5. Screenshots of the wallet (including errors or missing balance)

Did you find the solution? I am having the same issue with C.R.E.A.M validator.

Hash: CBFDC3F5A68DBA93A212189530C80B329EC87D61B3F8F814065E67086EA76323

@Nufcdurham try to reimport your wallet unstake again, here’s guide: How to Re-Import your Wallet

Iv just tried this, it hasn’t worked everything still appears the same.

I have a feeling mine may of been the same validator, I do remember seeing cream.

I have the same problem
The validator c.r.e.a.m doesn’t show
I re imported my wallet bud didn’t solve the problem
My bnb balance is correct but I can’t unstake or redelegate the amount that have been staked on c.r.e.a.m

Same here CREAM is not visible on staking screen. Followed instructions including import wallet - no luck. I have submitted support ticket but did not get response yet.

Yes exactly the same issue. Lets see what does Trust Wallet support @Alan47 recommend. Meanwhile if anyone finds a solution i’m all ears.

@Chuchundra , @zeeish
Can you try to reimport your wallet then redelegate to another validator or unstake your BNB

To redelegate or unstake I need to see that validator in list and I do not see it (I see my stakes with other validator).
To re-import - not sure I want to do that in case something go wrong I have no way to access whatever I have there for another validators. If I just import the same wallet under different name - isn’t it the same as re-import?

Same problem here. Screenshots from nufcduram show my exact problem. Plz either make the coins available or let’s us redelegate from CREAM to someone else.

Can’t do that as i cant see the C.R.E.A.M validator to unstake or reledelegate . Just have 1 validator in the list which is active. The other and the bnb staked are not shown.

tried that , and didnt work for me either :frowning: , hope this delegator didnt scam us

I’ve got the exact same issue with the C.R.E.A.M validator - it’s disappeared and I can’t unstake. :confused:

Hello all, app does not show staked balance from Decommissioned validators. We will fix it in the nearest releases.