Deposited Fetch tokens not credited

Hi Trust wallet team
I tried to submit a ticket but it didn’t work, I tried to transfer about 1230 Fetch token from Binance to my trust wallet but I didn’t get that even after 48 hours I will appreciate if you can share your comments

TxID: 0x1da09df9d832d6034ef85fd937d26776a72f2c3fdadf283db242ebb0cb5115ad
My wallet address: 0x6fc1e3Ff6A444eb7387fD0C7Dd2d4aebE349318A

I use Trust wallet on Iphone with latest version of 6.4(643)

1 Like

Hi, Please try to add it as custom token. Here are the steps that you can do to manually add the token: How to Add a Custom Token

Token details:
Network: Smart Chain
Contract: 0x031b41e504677879370e9dbcf937283a8691fa7f
Decimals: 18

Thank you so much Alan, It worked for me, I think I can transfer now? :brown_heart:

@alpha_section01 yes, transfer them no problem. But you need some BNB BEP20 (Smart Chain) for gas fee in order to transfer your tokens.

Thanks for your advice, how much BNB do I need for transferring all of them?

1 Like

@alpha_section01 just little about 0.0002 BNB.
You can learn more about transaction fees here: Cryptocurrency Network Fees

Dear Alan
I accidently transfer my Fets from trust wallet to Kucoin but on the ERC20, can i recover it?

@alpha_section01 Please contact the customer support of KuCoin so they can assist you with the deposit issue. If they are not willing to recover the crypto or credit your account, then, unfortunately, you may consider it as lost. Please be careful next time and triple-check before transacting.