Doge Coin Trust wallet transaction pending but no blockchain transaction

Hey guys.

I have recently tried to move my Dogecoin from Trust Wallet into my Binance Wallet.

I inputted the correct recipient address and how much doge I wanted to send over.

BUT, when I go onto blockchain to see the transaction when clicking ‘ more details ‘ there’s nothing there… it says ‘ oops we cannot find what you’re looking for’

1, have I lost my doge?
2, what else could it be?

Kind regards.


I have the same issue

I just tried to move my dogecoin to my binance exchange wallet 2 hours ago and it says still pending

When i look at transaction message says “oops cannot find””

What is going on Trust?

Please assist with this, did you guys change something without letting us know because never experienced this before.


Same here. I tried to move my dodge coin 1hr ago . Still pending and can’t find Transactions ID. When clicking on more details, nothing shows up . On top of that I can’t find a way to contact support. Even on Twitter they don’t allow message . I might go on Twitter to publicly get their attention regarding this matter


I have the same issue
I just tried to move my dogecoin to my binance exchange wallet 12 hours ago and it says still pending

Dogecoin trust wallet with no block chain history - #21 by hkazmi25 Check my other thread dude we did it!

I just got my coins back. It easy to do .

Use any wallet and import your trust wallet private key there. You will get your coin there automatically. I just use Atomic wallet and it works .

I download a new atomic wallet app and instead on creat new wallet , I choose the option of importing wallet. Then you put your trust wallet 12 key . Then make sure you refresh your app. Look for Dogecoin, then refresh it again . From there you can transfer it. And it will clear up in your trust wallet .”

I used crypto guys advice. I downloaded MetaMask, a different wallet on my iPhone. I put in my 12 word phrase and the dogecoin was there. I was then able to send it to an exchange. I received it within 5
Minutes of sending it! I hope this helps

Check the link in this thread dude we sorted it! Everything is in my Binance now!