Extract Private Key

  • Hi there,

I’m having a problem when trying to extract my Bitcoin Private Key on Trust wallet. I know it’s a third party, but I want to bring all my coins to Guarda.

Here’s the step I did:

  1. On Trust wallet, I copied my Bitcoin wallet address and recovery phrase

  2. Then, I pasted my recovery phrase on iancoleman.io/bip39

  3. Then, I got several addresses and private keys, but none of those correspond to my Bitcoin Address I previously copied in step 1.

Is that possible that the Bitcoins that are in my Trust wallet is only to view?

How do I extract my private key from my Bitcoin in trust wallet ?

Is there something I don’t do or do wrong?

5 Likes

Hi @bitcoinaire,

Make sure you BItcoin is the one selected in the coin.
image

Then, choose BIP84 in the derivation path so you can get the SegWit address

2 Likes

A post was split to a new topic: Wrote the wrong last letter

I followed your instructions.

However, when I use the public address I got from clicking receive BTC on blockchain.com, I don’t see the same fund balance that’s in my wallet right now. Why is that?

I swapped few times and sent some btc in another wallet/address, but don’t remember exactly.

For testing purposes, I used that private key that was beside that public key on iancoleman.io but a btc wallet appears but no balance. So why I am not even seeing my balance on the blockchain either?

Is it because Trust wallet use a HD ?

Also, according to Blockchain the Format to this address is BECH32

Do I really have the right address if I did follow the instructions, which is:

  1. I copied my address Received BTC in my Trust Wallet

  2. When to iancoleman.io, pasted my secret phrase, set coin to BTC, and path to BIP 84

  3. Then, past/search for my BTC address, which I previously copied

I am very confuse now. It should be simple isn’t. Copy my BTC address and past it to the blockchain and see all transactions. I tried to import that BTC address to a different wallet, but a new empty btc wallet appeared instead of my BTC balance that is displayed in my Trust wallet.

Basically I don’t seem to have the private key for my Bitcoin isn’t?
I swear I see them in my wallet with the amount, but for example when I go check on blockchain.com and past that address, the Final Balance indicate 0.0000000 BTC.

How do I find the right address so I can find my private key? Like I said I did followed all the step correctly in my opinion…

Perhaps, your address was changing and it used a different index.

  • Open the app
  • Go to the settings
  • Select “Wallets”
  • Press the 3 dots near the wallet that you are using
  • Export the public key (NOT THE PRIVATE KEY NOR THE RECOVERY PHRASE)
  • Copy the zpub of Bitcoin
  • Then enter it here: https://blockexplorer.one/btc/mainnet/xpub

After doing that, you can try to check for your addresses on iancoleman again.

Choosing BIP84 in the derivation path will yield to a BECH32 address.

I copied the zpub Bitcoin address and pasted it into blockxplorer. On this page I see a balance but not what it is supposed to be.

Then I went back to iancoleman, pasted my Mnemonic and I got addresses and private key at the bottom of the page. Then, I pasted my my public address I previously copied from Bitcoin wallet I found my address with private key but when I past this address to my explorer, I see some transactions but not my balance.

Please send the zPub here. If you prefer, you send it via private message.

zpub6qaKH2q7CWxH9fycgRNe5oYKVSfJH8XxfC6tcEbBR8cyJmnpavLzJxHdxhYrKTaKc1gJU8PNE6JYEYVCuzhu5RZoiiTMu4cyh2G5qKMpMEv

When I enter my zPub to BlockExplorer, it’s not my balance that is displayed.

It should be simple isn’t?

This is my BTC address which I copied from my Trust Wallet, which the app is dowloaded on my NEW iPhone.

bc1qrakqnql57ka9cw3l8xfc0ct0rvqqgafdc6phqm

This one is my BTC address which I copied from my Trust Wallet, which the app is dowloaded on my OLD iPhone.

bc1q90ap3un2f38r4peqcx9jm7mssj34gym33yhmv3

First, why do I not get the same BTC address on both iPhone (trust wallet app)?

Both Trust Wallets app have the same Recovery Phrase and the zPub:

zpub6qaKH2q7CWxH9fycgRNe5oYKVSfJH8XxfC6tcEbBR8cyJmnpavLzJxHdxhYrKTaKc1gJU8PNE6JYEYVCuzhu5RZoiiTMu4cyh2G5qKMpMEv

When I past both addresses into Search on iancoleman.io, both got yellow marked. So I thought I found the right two addresses along with their private keys. But when I pasted both public addresses on the blockchain, both addresses are empty.

This address is empty according to blockchain.combut on my wallet trust app I can see my BTC.

bc1q90ap3un2f38r4peqcx9jm7mssj34gym33yhmv3

This address doesn’t reflect my total balance, but again on my wallet trust app I can see my BTC.

bc1qrakqnql57ka9cw3l8xfc0ct0rvqqgafdc6phqm

Just to test those private keys, I also tried to import both BTC addresses I found to another wallet Guarda. Both wallets successfully imported but no BTC displayed in it.

I am confused. Please help me.

Thank you for providing the zPub. Upon checking, it looks like your address was changing for your privacy. Learn more here:

Here are your previous wallet addresses which you need to find in iancoleman:

  • bc1qedwx3xpj9370r80avhrms9xftqxx64axnjuh2c
  • bc1q3hpgcr47sffcaf0fvvcletk569paphw02aj2ya
  • bc1q786le96awkh63swkvtk2t6xwny9l78wq599p0d
  • bc1qkreszesqfy4x8zzx59x027uf5xmpx6u32ay3qa

I found the FIRST public address and private key: bc1qedwx3xpj9370r80avhrms9xftqxx64axnjuh2c
However, when checking on blockchain.com, the Final balance doesn’t reflect what is in my wallet.

The second and third, I could not find them at iancoleman:
bc1q3hpgcr47sffcaf0fvvcletk569paphw02aj2ya
bc1q786le96awkh63swkvtk2t6xwny9l78wq599p0d

I couldn’t find the fourth one address either: bc1qkreszesqfy4x8zzx59x027uf5xmpx6u32ay3qa
But when checking on blockchain.com, I found the balance that is close to what I have in my wallet.

I can’t believe this is so hard :frowning:

Try to enter 1 in the external/internal part.

Wow so tired of this stuff!

When entering 1, I found the private key for this address: bc1qkreszesqfy4x8zzx59x027uf5xmpx6u32ay3qa

Then I tried to import this private key to my other wallet, a btc popped but no btc inside.

I am suppose to have the right BTC address cause I do click on BTC Receive/copy within my Trust wallet. However as I mentioned before, my BTC address is different from my new iPhone and old iPHONE but the amount displayed is the same!

NEW IPHONE BTC address bc1qrakqnql57ka9cw3l8xfc0ct0rvqqgafdc6phqm

OLD iPHONE BTC Address: bc1q90ap3un2f38r4peqcx9jm7mssj34gym33yhmv3

After three weeks of patients and back and forth chatting, is there someone who is going to help me out???

Why does it take so much time to help me fixing this issue?

Private should be extract within the wallet. What is this mess?

I am piss beyond believe now!

Using the12 phrase can only let you view you wallet account.
You must copy your bitcoin wallet address - private key.
You must keep this Private Key safe at all times.
Click settings,
Click Wallet (showing at the top)
Find the name of your Wallet
Click the 3 dots next to your wallet’s name
Click export Account Public Keys
Choose Bitcoin Keys

Did you follow the above conversation before answering me this?

I have no problem to find my public Bitcoin address. This is the one I copy when clicking on Bitcoin isn’t?

But how do I get to see my BTC private address?
It is not in my Trust wallet by default isn’t? That is why someone told me to go on iancoleman.io
and enter my 12 words, choose Bitcoin, Derivation Path BIP84, and set External/internal to 1.

The only other address I found for BTC is the zpub one.

Is there anybody who understand what is wrong and how to find my private key???

I did followed all the instructions so far!

THERE IS NO PRIVATE KEY IN MY WALLET. ONLY MY BITCOIN PUBLIC ADDRESS.

Your BTC balance should appear. You have 1.32018521 BTC for bc1qkreszesqfy4x8zzx59x027uf5xmpx6u32ay3qa.

Also, after entering 1 in external/internal, you should be able to see these addresses and get its corresponding private keys:

  • bc1q786le96awkh63swkvtk2t6xwny9l78wq599p0d
  • bc1q3hpgcr47sffcaf0fvvcletk569paphw02aj2ya

It’s intentional. That’s why I’m guiding you on how to extract the private keys.

1 Like

I have 1.33239269 BTC as you can see on the attached screenshot of my Trust Wallet BTC.

Not 1.32018521 BTC as I can see from this address bc1qkreszesqfy4x8zzx59x027uf5xmpx6u32ay3qa.

On iancoleman.io, I extracted my private key from this address bc1qkreszesqfy4x8zzx59x027uf5xmpx6u32ay3qa

and I do see on blockchair.com the amount you are refereing 1.32018521 BTC. But it is not exactly the same amount I see in my Trust wallet.

I also took the private key I just extracted from this address bc1qkreszesqfy4x8zzx59x027uf5xmpx6u32ay3qa
and tried to import this 1.32018521 BTC to Guarda. A BTC wallet opened but there is ZERO Bitcoin.

The amount is almost the same/close but like I said, when I try to import those 1.32018521 BTC to Guarda, zero bitcoin appear.

When I copy my BTC address on Trust wallet this is the address I got: bc1qrakqnql57ka9cw3l8xfc0ct0rvqqgafdc6phqm

Then, when I pass this address on iancoleman.io, no address found.

Why does it take forever to answer me?
I need some help to figure this thing!!