Failure to receive ftm currency to trust wallet

سلام من ارز خرید کردم ولی به کیف پولم انتقال داده نشده است، شناسه تراکنش را ارسال کردم


The Trust Wallet app does not support the native FTM.

To retrieve it, please get your recovery phrase (here’s a guide: How to Backup a Multi-Coin Wallet), then, import it to their official wallet (choose mnemonic phrase): Fantom fWallet

Hi can someone please help me here also.

I purchased FTM form pancakeswaps as BEP20, expecting them to show up in the trust wallet because FTM BEP20 exists there under all available coins.

I see here this is not the case, I tried to go in the FTM website as proposed, used my security sentence to gain access to my wallet, but the FTMs are not showing as this thread also explains. I don’t know what was done to make those show up?

Please help

Hello @Aleko To better assist, please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)

  2. Crypto wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here. Also copy and paste it in plain text)

  3. Transaction hash or link (if you have any, please copy and paste)

  4. Further details about your issue (please explain what you were trying to do)

  5. Screenshots of the wallet (including errors or missing balance)

Hi, I have the same issue.

  1. I have Trust Wallet version 2.10
  2. Address I tried to receive at on TW is 0x1eb0de02263a714a1f51fc311f987b73894d9eb5

This forum won’t let me attach media, so I can’t post a screenshot.

  1. Link for transaction is ETHERSCAN: token/0x4e15361fd6b4bb609fa63c81a2be19d873717870?a=0x1eb0de02263a714a1f51fc311f987b73894d9eb5
  2. I sent from Metamask to FTM on TW. It never showed up, and I gather this is because there are, for some reason, multiple FTM
  3. I’m not sure how take a screenshot of my FTM on TW, since it just comes up blank.

Any thoughts on what I should do? I connected TW to pwawalletDOTfantomDOTnetwork but it still shows no balance (sorry, it also won’t let me post links)

Hi, Please try to add it as custom token. Here are the steps that you can do to manually add the token: How to Add a Custom Token

Token details:
Network: Ethereum
Contract: 0x4e15361fd6b4bb609fa63c81a2be19d873717870

You’re a lifesaver! That worked fine for me, and I can see it now. Thank you, sir. Have a great day