GALA is not showing up in wallet after swapping on pancakeswap

I used pancakeswap to swap smartchain to GALA and it never showed in wallet. I have added the token using the slider on the top right of the app. I have also tried to manually add it with no success. I have deleted the app and reinstalled it, restarted the device and still nothing. If I connect my wallet to pancakeswap it does show the balance that is supposed to be in my wallet. I even tried to swap GALA back to BNB and that worked and showed in my wallet. When I tried to convert it back to GALA it showed back in the balance on pancakeswap but not in my wallet. I am at a loss here. Please, if anyone has a solution help me

IOS trustwallet version 6.11(6111)

Wallet: 0x50fbd8852e1ceD638977B557c24e0Ce5F3eE7957

TXN hash:

Hello @Mckilla51
Your tokens are in your wallet and you only need to add it manually as a custom token using these details
Network: Smartchain
Contract: 0x7ddee176f665cd201f93eede625770e2fd911990
Decimals: 18

Hello @JennyMillan
Thank you so much for your help. It worked. You’re AWESOME