Have a problem to unstake my osmosis

Hi i have a problem to unstake my osmosis. There is an error shown.

Such as how do i solve this

1 Like

Hi @Johnbra,

Thank you for reaching out to us! Please send the following information so we can understand more about your situation:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)
  2. Android or iOS version of your device (please take a screenshot and upload it)
  3. Crypto wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here)
  4. Transaction hash or link (if you have any, please copy and paste)
  5. Further details about your issue (please explain what you were trying to do)
  6. Screenshots of the wallet (including errors or missing balance)
  7. Video recording of the issue (you can upload it via Google Drive, then share the viewing link here, and make sure the permission is updated [example: https://i.imgur.com/o4f1ABK.png])

Heads up! Please be informed that we will never ask for your seed phrase; talk to you via email, WhatsApp, Telegram, or other platforms. Be vigilant against scammers and impersonators, and report them to us immediately.


I cant claim rewards and cant unstake. Pls help!

1 Like

Thank you for providing more information!

Please try to change the node for Osmosis by doing the following:

  1. Go to the settings
  2. Select “Preferences”
  3. Choose “Node Settings”
  4. Look for Osmosis
  5. Turn off non-auto, and select a different node from the one that is currently ticked.
  6. Go back to the Wallet page and try to transact with your Osmosis tokens again.

Please let me know if it worked or not.

1 Like

Thank you so much. It finally worked. Managed to claim rewards and unstake. Appreciate it. Maybe you can pin this post or make an FAQ about this issue. Tyvm

Awesome, glad to know that @Johnbra! Good suggestion as well :smile:

A reminder to always stay safe while exploring the crypto space, have a read:


This topic was automatically closed after 10 minutes. New replies are no longer allowed.