I have ERC20 BNB, need help!

Hi, Richie’s issue seems the closest to mine, maybe out of the two issue we’ll give more info to those that search later for resolution to similar dilemmas. ~~ I have what appears to be ERC20 BNB in both Trust Wallet and MM. I have it in both so I can try fixes from both, The token acts like it does not belong on the network or like a ghost. ( or has some old broken code) Can’t be swapped in MM ( does not show up in swap window). In uniswap, it says Insufficient Liquidity, ( got enough eth for a swap,) . In Trust Wallet, If the token were in good shape, there should be a ‘more’ button to the right where I could swap it back and forth form ERC20 and BSC, but that button is not there. It can not be sent to any erc20 DEX, throws invalid address, can not be sent to any BSC wallet or dex… does not show up. You help would be Great!!! Cheers!


Hi @osovox,

You need to deposit it to Binance so you can get the mainnet token.


Respectfully, I have 4 Binance chain accounts the coins to not show up. MetaMask’s Binance network, fully set up! used many time with BNB,/ trust wallet, swapped many time back and fort. or set to and received. / Binance-us on had one failed to arrive./ and Brave/chrome Bianace Wallet. coins did not arrive. tried sending the coin s to all 4, they do not show up. Am I missing something? can you give me a step by step,/ Thanks

To better assist, please provide us the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)
  2. Crypto wallet address of the cryptos that you are trying to transact
  3. Screenshots of the wallet (including errors, if any)
  4. Video recording of the issue (you can upload it via Google drive then share the viewing link here)

Hi @iamdeadlyz…does this screenshot mean that to convert my erc20 bnb tokens, I deposit them to my erc20 eth address on binance?

Hello @snickelfritz09,

Yes, Binance.com accepts it and they will convert it on their platform.

Ok, so I’m now hitting an issue of needing $nkn (?) to send?

I’ve got wallet version 5.16 (5166)

Address is: 0xCc8d9CAF8bB04EE1D89409F48b3F4EE9B641FaF3

I tried linking a vid and screenshot but forum isn’t allowing me to.

I’ve also tried using eth as bep2 and bep20 for the gas and getting that same error.

Please try to attach a link and/or screenshots again.


Here’s the screenshot

The vid: https://drive.google.com/file/d/1wgplN4CKnNuLiSLXtam0OUq4kQLwzDRs/view?usp=drivesdk

Thanks for reporting, this bug has been relayed to the devs. Please ignore NKN for now.

Upon checking your wallet, you don’t have any available ETH to spend on network fees.

You can buy ETH using the app or withdraw from an exchange like Binance.com (choose ERC20 as the withdrawal network).

Additional: Please re-import your wallet by following this guide to fix the NKN issue.

1 Like

@iamdeadlyz awesome!! That worked!! Thank you so much

1 Like