I purchased SafeBTC tokens it didnt really show up correctly

i have a similiar issue when i purchased SafeBTC tokens it didnt really show up correctly i tried to internally transfer it to safemars its gone but not refreshing

i would post a sep question but i cannot post new topics so sorry for jumping your thread or a similiar issue

1 Like

Hi @rborhara,

To better assist, please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)
  2. Smart Chain BNB wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here)
  3. Transaction hash or link
  4. Further details about your issue (please explain what you were trying to do)
  5. Screenshots of the wallet (including errors or missing balance)

To access it, tap the toggle sign on the upper right of the main wallet screen, search for safebtc, and enable the one with BEP20. You can also follow this guide: How to Add or Remove a Coin


Also, be informed that sending SafeMars to another token like SafeMoon won’t automatically swap it to the preferred crypto. The same goes for all cryptocurrencies. The transactions that you did earlier where you supposedly sent SafeMars to SafeMoon was a “self” transaction. Meaning, you only sent it to your own address, and it still remained as SafeMars.

Ok so i searced for safemoon and they were already enabled (non BEP20 dont exist , so disabled them - closed wallett and reenabled them still no different
SafeMars is at the bottom

What are you trying to achieve now? Can you please clarify what are you aiming for?

I am experiencing the same challenge.
You see the units bought but there are funds/money associated with it reflecting i.e. No currency amount, so the total value of the wallet excludes the amount you spent on the coin. Please assist

well i have £50 that was initially pumped into SafeBTC, that isnt really showing , that i tried to move to SafeMars and it hasnt even moved into there. SO £50 is lost in the system

@Fhumu, please read this:

@rborhara, are you referring to the pricing data? If yes, please read it as well so you’ll understand ^

1 Like