Imported a wallet, but zero balance

I imported a wallet with my seed words, but it shows zero balance in the Trust wallet.

What to do?

2 Likes

Imported another wallet, same thing there, shows zero funds.

Why?

1 Like

Hi @working,

Please read and follow this guide (except step 6, no need to submit a ticket):

5 Likes

Went through all the points

  1. I have BTC and ETH in my original wallet, and I am 100% they are still there in my original wallets.

  2. I am looking at my original wallets, the BTC and ETH is still there, so I have crypto in my wallets.
    I chose “I already have a wallet” inserted the seed words from my original wallet, and it says it is successfully imported.

  3. I am connected to the internet, no VPN, live in a crypto friendly country no sites are blocked here.

  4. Deleted and re-installed the wallets, inserted seed words, it says successfully imported. Still no funds showing.

6 Likes

Please try to use a VPN, it is worth a shot. Also, switch to WiFi from mobile data or vice versa.

1 Like

Switched between mobile data and Wifi, rebooted my phone.

Don’t have VPN subscription currently. Have been dealing with crypto for more than 3 years, never ever had an issue with blocked sites or apps.

2 Likes

To better assist, please provide us the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)
  2. BTC and ETH wallet address (press receive, take a screenshot, and attach it here)
  3. Screenshots of the wallet (including errors, if any)
3 Likes
  1. Trust wallet version 1.26.14

  2. ssh One of the BTC addresses

  3. No errors. One of my wallets is blockchain.com

2 Likes

And thank you for helping me out

Please attach screenshots of the wallet, even though there are no errors.

Also, please give me the zPub of Bitcoin:

  • Open the app
  • Go to the settings
  • Select “Wallets”
  • Press the 3 dots near the wallet that you are using
  • Export the public key (NOT THE PRIVATE KEY NOR THE RECOVERY PHRASE)
  • Copy the zpub of Bitcoin
  • Then send it here
2 Likes

Is it possible to DM the zpub to you?

1 Like

Yes, you can. Press the message button here: https://community.trustwallet.com/g/moderators

2 Likes

Tried to DM you, but it says, sorry, iamdeadlyz doesn’t accept msg at the moment.

1 Like

Click the link that I sent, then press the message button.

image

1 Like

It looks like I will send to all the moderators. I feel uncomfortable leaving zpub in the open so to speak.

1 Like

That is the way for now. You can trust the moderators here. If you prefer, I will immediately delete the zpub after you sent it via the moderator message or by posting it here.

2 Likes

Thanks ok, I do know I am a little paranoid and probably shouldn’t worry, I just feel very uncomfortable sharing detailed wallet info.

Right now I am a little too chicken to post to all moderators, even though I know you will delete it as soon as possible.

Hope you understand.

3 Likes

Same thing happened to me to, i restored my wallet today after switching phones, apps is on latest version, my balance is 0. Do you guys have problems with developing this app or?
I see many posts having same problems like us

5 Likes

@working, check your message notifications.

@njakonjakic, depends on the situation. Please read and follow this guide (except step 6, no need to submit a ticket): My Crypto is Missing, What Should I Do?

2 Likes

Thanks so much, and sorry for my late reply.

I have been thinking, and I just got very uncomfortable with the details.

I do trust you, and appreciate your help. I will contact you later if I get a better feeling about giving out my details.

Once again, thank you man!

1 Like