Lost funds not existing address

Just lost 100 USTD when trasfer them from trade to wallet. I got confirmation from that transfer is successful from the trade and funds don’ t arrive in wallet. When chek to explorer it say that the address of the wallet dies not exist

1 Like

To better assist, please provide us the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About” and attach it here)

  2. Crypto wallet address (press the receive icon near the send button, and attach it here)

  3. Transaction hash or link (if you have any, please copy and paste )

  4. Further details about your issue (please explain what you were trying to do)

  5. Screenshots of the wallet (including errors, if any)

Hi Alan,

Thanks for your reply :

  1. version of wallet is 1.29.3 ,
  2. crypto wallet address is - 0x6f4e9823C7978CFB0cF2B80CEd83A4149a502EB6.
  3. transaction hash - 0xcc7f88bf238b4ec853f226e330e6d2f53a1c16709cc16f1bf5e9b3df29130968
  4. I was trying to transfer part of my funds to wallet in order to swap them later on pancake. Strange thing is when i go to pancake i see the usdt in pancake swap but not in the wallet!
    i try to upload media files but it seems i`m not allowed

Hi, please tap on top right corner and search BUSD-T then switch on BUSD-T BEP20 manually. This guide can help too: How to Add or Remove a Coin

added the BUSD-T BEP 20, but still no funds shown. As well when i try to send back funds to my Binance account it says cost of transfer are almost 30 $ which is insane

Can you click on Enabled usdt and send screenshots here please, and address screenshot (click receive button and screenshot).
But if it is still not visible how do you access it and try to send to Binance?

@Dim4u you enabled USDT ERC20 which is not the currently you have in your wallet. Refer my message above on how to enable USDT BEP20.
I sent also screenshot below, type the words as they appear on screenshot and enable.

1 Like

I will now attach a screenshot of pancake , where you can see that pancake linked to my wallet sees the funds in it, but the wallet can not see it.As well i don`t think pancake also works as it does not allow me to swap - it says insufficient balance

GOD! THANK YOU! finally here! :handshake: ok, so now i can continue to swap eventually, Thank you once again for the help!

1 Like


Like the message on screenshots says… you need Smart Chain BNB as gas fee to cover your transaction fees.

Hi Alan,
so as far i understand i need to buy/mine BNB in order to do the swap in pancake and can not be done with the currency i own? Is it the same when i swap in the wallet between 2 currencies? Appreciate your answers - learning new things!

Yes, any transactions whether transferring from wallet to wallet/exchange or swapping… both needs transaction fees.
Read more about network fees here: Cryptocurrency Network Fees

About blockchains and their corresponding fees: Blockchains that Require Network fees

Well i have top up 30 $ in BNB , tranfer them to the wallet as well and still can not perform any transactions - neither swap or withdrawals. Obviously i`m not doing something the right way.

From the Smart Chain address you sent above… there’s no BNB only USDT. To be able to transfer you need BNB BEP20 (one with dark logo) and your USDT BEP20 in same wallet. Probably you have BNB BEP2 (one with yellow logo), if so, swap some amount of your BEP20 BNB to BEP2 to be able to get gas fee. Here’s a guide on how to swap: How to make a Crosschain Swap on Trust Wallet

I have figure it out it should be Binance smart chain as you say dark logo - not the yellow one. Thanks!

Hi I sent eth from binance to trustwallet 4 hours ago and still hasn’t arrived any advice?

1 Like

As Alan said in previous post - have you enabled the correct currency in the wallet?