Missing Cosmos ATOM tokens

Version is 5.14 (5143)


thanks for confirming. Yes very strange, one minute Mint returns my funds, next minute 404. Really appreciate your quick reply.

1 Like

@turnerc13, the video link is inaccessible. Please make it available for viewing.

Give it a try again.

Got access, thanks! The dev team has been informed about this one. Please wait for their updates.

Hello! I can’t access my wallet atom info on mintscan. I’ve made a request on binance to refund my atom (4 atoms), and I don’t know whether they didn’t refund yet or just my wallet doesn’t work. Any recommendations?

My atom address is cosmos1qrlz445ln0csmznaasu899hzwnkju3pkweully
Somehow can’t add an image

I bought some Atom And I want to Transfer to my trust wallet. But I Receive the Error (your wallet is suspended).
It didn’t happen for other cryptos.
and Also there is a massage “Cosmos Network is temporary not available due to network upgrades. Wait for new app update within the next couple of days"
should I wait more for the updates?

@iamdeadlyz I can not unstake & claim rewards, because I staked ALL ATOM to begin with and it is asking for 0.001 ATOM to unstake and another 0.001 ATOM to claim rewards, why would it not just deduct this amount from the rewards or stake upon claim / unstaking, I am stuck as it is also giving me an error when trying to buy a bit more ATOM with BUSD. also I get the same message as others report “Cosmos Network is temporary not available due to network upgrades. Wait for new app update within the next couple of days.”. and it’s definitely already been more just a couple of days and I am looking to make trades and can’t. iOS app version 5.14 (5143). Thank you for your help.

У меня тоже пропали cosmos atom. ЧТО ДЕЛАТЬ?

The problem is the ATOM coins disappeared. When will this problem be solved and what do I need to do?

Hi, the latest Trust client is still not available in the play store. Is there any other way I can move my Atom?

Can you please help me send my ATOM? Its in my Trust Wallet, when i put the address and the memo and click “next” a message comes up saying something went wrong to try again. I am using the latest version on IOS

1 Like

I am having the same issue, I am new to Trust Wallet and it has been a complete nightmare. Has the IOS app been submitted to Apple yet?


Hi @paniz.jafari, @flowalker, @3_gger, @dimka1, @wigg, @apoKrypto.

Apologies for the inconvenience. The Cosmos network recently updated, and it requires all nodes to upgrade. This affects all wallets, not just Trust Wallet. Kindly wait for the network to be stable and thank you for your patience.


I understand. however I can send to trust wallet fine, meaning that the network is communicating fine?

Hello @wigg, transacting should be ok now. Please make sure you are using the latest version of the app (android: 1.26.14, iOS: 5.14) and that your internet connection is strong enough as well. Try to use a VPN as well. If it still encounters an error, please backup your recovery phrase, re-install the app, import the wallet, and try again.

Where can we get the latest version? I updated off the play stor but it’s only 1.26.11

I am having the same issue with my atom tokens not showing up in my wallet

Hi @heavychains,

The Google Play store takes time to distribute the latest version. Try to check after a while.