No option to approve transactions on dapps

Hope you can help.

Until mid January my trust wallet worked fine but since then whilst I can connect to dapp’s and uniswap using walletconnect, it doesn’t give me the option to approve any transactions.

I have tried deleting the app and reloading the wallet and tried on different devices but it still won’t work. Any ideas?
Thank you


For a month I have had similar issues, I can connect with the relevant dapp via walletconnect, but when I try and do any transactions that require confirmation my trust wallet doesn’t give me the option to. This is the same in uniswap.
I have raised queries via the help page but haven’t got a reply

1 Like

Hi @Stuf,

Are you using an Android or iOS device? What is the Trust Wallet app version? (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)

1 Like

Thank you.
I am using iOS devices.
Here is a snapshot.

Please enable the DApp browser by following this guide:

After enabling, please use that one instead of other browser apps.

1 Like

Thank you. That worked a treat.

Best regards

1 Like

Great! Glad to know that. If you have other inquiries, feel free to create a new thread/topic. Stay SAFU!