Please help BNB not showing in my wallet

I purchased BNB Smart chain from simplex on trust wallet. Not sure if I messed up buying the smart chain directly instead of BNB and swapping but I sure hope not. Its been hours and its still not in my trust wallet. I checked my id on the blockchain (I think) and it does not show on there. I got a email conformation from simplex saying everything was approved but still nothing and the money was taken from my account but I still have not gotten anything in my wallet. I have reached out to the simplex support and they are useless. Is my money just gone or what can I do?


I tried to convert 3 BNB to Smart Chain on Friday and they disappeared! I tried to convert 7 BNB early this AM to Smart Chain and they to disappeared. I was dumb enough to try it one more time about an hour ago and 3 BNB disappeared. Where are they going and will I ever get them back???

When I check my wallet by “BNB” or “Smart Chain”, they only show my original 3 coins from last Friday, they don’t even show any record of the other coins ever existing in my wallet! I was concerned that I had a bad app (read about it re the Apple App Store stocking bogus Apps), but it does appear to be the correct Apple App. What is going on? Can I expect to hear from Trust Wallet, and do I have any recourse? From what I am reading here, I am guessing that I am out of luck. Any assistance would be welcomed - thanks

Has anyone heard about this occurring?

I have only purchased once early this am but have not gotten my funds. Simplex assures me it will be delivered but at this point im over it. As far as recourse goes I have no idea but I will be calling my bank to dispute this at the very least and try to get the money I paid back not sure if I can or will but it doesn’t hurt to try. I wish I had seen all of these articles about trust wallet prior to my purchase or ever getting involved with it.

I’m currently in this same boat. Bought bnb which went perfect but while trying to swap I kept getting insufficient balance. So I thought if I’m swapping to smart chain anyways let’s buy that instead. I never received the Smart chain purchase!

I just purchased BNB twice and…

  1. It doesn’t appear in my wallet
  2. I didn’t receive any type of notification to my email address

Anyone from TrustWallet want to reply?


Yup having the same issue I purchased yesterday and nothing as of today…

1 Like

Used a card to buy bnb chain today and still not received after 8 hrs , done the normal things like update etc the transaction was taken from bank showed a approved by simplex and then nothing so whats next !

1 Like

Same issue, BNB received, showing receipt amount & time/date stamp but not showing in balance. Seems a common issue @support help?

Did you ever get it ? Wondering because the very same thing has just happened to me

There’s a YouTube video up now just change name
Of main wallet save then click on them stars where ya balance would be at it should show … clicking stars turns balance off and on

Could you share that link please, I can’t find the video! I also have that problem

I just bought BnB but nothing on my trust wallet :frowning: 2f2ce255-1783-4446-be25-fbd8cf7fd365

@Gembel21 To better assist, please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)

  2. Crypto wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here. Also copy and paste it in plain text)

  3. Transaction hash or link (if you have any, please copy and paste)

  4. Further details about your issue (please explain what you were trying to do)

  5. Screenshots of the wallet (including errors or missing balance)

All coins have been transferred out of wallet with exception of BNB. The BNB stacked coins have also been un-stacked and currently in the 7 day lock period. I did not unstack my BNB. So, if this is not corrected I will also lose all BNB.
Please give assistance.
Also tried submitting a ticket but continually get “failed Captcha attempt”.

Sorry to hear about your recent experience. Here are the possible reasons:

  1. You shared your 12 words (via phishing, social engineering, etc.);

  2. You saved your 12 words in a very bad place;

  3. Your device is corrupted with malware;

  4. Someone had physical access to your device;

  5. You entered your recovery phrase on a fake/clone app.

  6. You transacted with a malicious DApp.

Unfortunately, confirmed transactions at blockchain are irreversible.

Please read and understand this:

Learn more about how to protect your cryptos and new wallet:

Thank you for the guidance. At this point I am hoping to save my remaining BNB that are currently in the 7 day locked in-staking period. Unfortunately, I did not un-stake and am fearful that these funds will also be stolen once the staking period ends.
I have created a new wallet in hopes that hat I can transfer the BNB after locked period ends.
Any suggestions as to how I could possibly transfer before thieves beat me to the transfer?