Refinable Pancakeswap - Tokens went missing - need help

So I just swapped my BNB for refinable that just launched.
I used my trustwallet BNB for this and it says that the transaction failed, yet if I look up the TXID it says success, but I never actually received the refinable tokens back on my wallet.
What can I do, or who do I have to contact?


Hi @Hybris95 Please try to add it as custom token. Here are the steps that you can do to manually add the token: How to Add a Custom Token

1 Like

I am also missing mine, and when I try to create a custom token it is not showing any of my tokens either


Same here, I am also missing mine.
I have even tried adding the custom token to my list, but it doesn’t do it.


i am missing my funds. transaction shows ERROR and about did not come back. please advice

1 Like

To better assist, please provide us the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About” and attach it here)

  2. Crypto wallet address (press the receive icon near the send button, and attach it here)

  3. Transaction hash or link (if you have any, please copy and paste )

  4. Further details about your issue (please explain what you were trying to do)

  5. Screenshots of the wallet (including errors, if any)


I was doing the same token swap. the transaction showed error. amount was not reverted back to my wallet. please advice.


Same here. Error occured. BNB Smartchain amount popped back twice for a couple of seconds and disappeared again twice. Still hasn’t been refunded. Doesn’t show in my history anymore. A purchase of Elongate after my Refinable that did go through also doesn’t show up in my transaction history. What a nightmare…


When i tried to buy $fine All my transactions failed and my BNB tokens are missing now

1 Like

I have 2.8m FINE shown in my wallet but its not showing a value below. Checked Bsc and all success - how do I make this work?

1 Like

hi ive got the same problem with Aquagoat. Bought 35,484,608,482 via pancake swap but the trust wallet is only saying I have 3,548,492,817 so 32 billion short . Would you know how i fix this? All shows that the transtion was correct on bscscan

1 Like

Version 5.21



When I try to add as custom coin it doesn’t work, and I can’t see any Fine Coin in my account please help

1 Like

1 . 5.21 (5210
2. 0x120fa018641ADACE3b6dc5790f81D5EFF6fAF5E0
3. not available
4. Was trying to swap smart chain to FINE
5. says cant embed media item in the reply

1 Like

Hi @georgem1988 check these 2 articles about pricing info on Trust Wallet:

Version 1.28.8 I don’t have a wallet for the refinable. The wallet I was making transaction with was smart chain bnb 0xA31628Dd82E147a864c3962E845E4f4A082e6E3e
Transaction hashtag 0x55cac88c45b2985e590577637fb03efd1268fb670ba2455412249f953ddd795d
Was buying refinable with smart chain bnb. Transaction says success.

Similar, it doesnt show any numbers any more only ****
Pancake shows i have assets?

Hello guys, make sure you followed the instructions according to this article also use VPN: How to Add a Custom Token

I followed the steps.

  1. Select smart chain on network selection
  2. Contact: 0x4e6415a5727ea08aae4580057187923aec331227
  3. Name: Refinable
  4. Symbol: FINE
  5. Decimal: 18


Yes, I had a different variant. 0.5 bnb returned to my wallet. Then I looked in my wallet and saw the number of BNB change several times and then it said 1.663861. This is not right, because that 0.5 bnb has to be added so now it has disappeared. What kind of hassle is this? I have an overview from BSCscan where it says exactly how much BNB is had before the swap and after the swap. 0.5 Bnb has disappeared. Who is going to solve this?

Tap on **** above. See screenshot.

1 Like

help i wanna transfer fine back to bnb but I won’t let me. it say Its allright send but the value is 0

1 Like