Renistalled trust wallet and now cant find my vechain

My phone was playing up so i reinstalled trust wallet. entered correct phrase words etc. but when i managed to logon my vechain is set to zero. can you please help?

1 Like

Hello, try to:

  1. Update your Trust Wallet App to latest version <— always do this first!
  2. Reboot your device <— often resolves issues
  3. Update your iOS/android <— same
  4. Try using a different Network provider (WiFi, 4G, cellular, etc.)
  5. Use a VPN
  6. Reimport your wallet <— do this only last.
  7. Reinstall the application, don’t forget to backup your wallets before doing it so

Give the above a try in order and let us know

Thanks for getting back to me. I have tried all the above and still nothing.

@Jaymck thanks you for the feedback. Can you provide me those informations:

  • Trust wallet app version
  • VECHAIN token/coin address (yours)
  • A screenshot of your coin/token in trust wallet app

Please see requested info

  • Trust wallet app version - version 7.16.2
  • VECHAIN token/coin address (yours) - 0xF70db160335E120035B5C7dAF05285000fbEBfcB
  • A screenshot of your coin/token in trust wallet app

@Jaymck from vechain explorer, you don’t have anything in this wallet

And you have some VECHAIN that worth nothing on binance smart chain network

Which one are you trying to see ?

please see attached

thats very strange, i do have some Vetchain in trust wallet. I know i dont have anything Binance because i had moved them to Trust wallet a few months ago.

@Jaymck Yeah, try to add vechain from bep20 network and let me know

Tutorial here

tried thanks and still no Vechain. I know i dont have a lot but I just dont understand how its missing

1 Like

@Jaymck I just imported your wallet through watch only mode and was able to see your vechain. Can you show me what kind of vechain you did import into your wallet ?



oh ok. I must be doing something wrong. btw the new version seems a bit different from the last version of trust wallet.

@Jaymck seems like you aren’t importing the right token. Let me send you a screenshot of the token you should import

Thank you for that. I was doing something wrong. I have imported the correct but however it still showing zero. I have tried to restart my phone etc. Please see screenshot.

Thanks @Jaymck, I got it. Can you try to:

  • Backup your words, delete your wallet and then import it. Try with your mobile data, WIFI and VPN
  • Backup your words, reinstall the application and then import it.
1 Like

Thanks, i have tried the above but no luck. I appreciate your help and patience

@Jaymck lets try one more thing,

  • Import your wallet as watch-only wallet through the token address and let me know if you are able to see your funds or not, because we have the same version of trust wallet (7.16.2) and it’s the latest one. After you tried, I suggest you to reboot your device, connect to a VPN before opening trust wallet, clear application cache and data and import back your wallet through your words.
    Give it these two a try and let me know

i reinstalled using another phone. everything is working now and can see my VET. thank you so much for your help and for being very patient with me.