Sent usdt bep2 from binance to trustwallet, but the balance is 0

Hi, sorry before. I have send usdt bep2 from binance to trustwallet. In trustwallet already received but balance is zero. I don’t know how to post questions so i reply in this topic. Thanks for your support

Hello @Denis3,

To better assist, please send the following information:

  1. Trust Wallet app version (open the app, go to the settings of the app and press “About”, take a screenshot, and attach it here)
  2. USDT BEP2 wallet address (press the receive icon near the send button, take a screenshot of the QR code, and attach it here)
  3. Transaction hash or link
  4. Screenshots of the wallet (including errors or missing balance)
1 Like

Thanks for your support

Try a full reinstall of the app.
Make sure you have a backup before you proceed.

Uninstall and then reinstall your app.
Follow this guide to restore your wallet.

1 Like

I already uninstall tw app and reinstall app. Nothing change. I already follow instructions you have give.

Try to use a VPN then refresh the balance. Let me know if it worked or not.


Nothing change same. I already refresh more and more. Balance 0. Its that possible heavy traffic?

Hi, sorry for replying the exact problem I’ve encountered here. I also sent 10 USDTBEP2 from Binance to Trust Wallet.

Successful, but the balance still shows zero, null, nada.

Already reinstalled the app, and re-login. Still zero.

Trust Wallet Android App Version 1.28.1

Transaction details


@setrum @Denis3

Please send a screenshot here where you are using VPN yet the balance is not updating. By the way, there is a new version (1.28.2), if it’s already available in your play store, please update to that one.

Sir please can you help me? I’m a very small user. I somehow managed to save only 30 dollars and deposited it but mistakenly I deposit it wrongly in USDT BEP 20. now I can’t swap it. Because of the BNB zero issue. They say you don’t have enough fee. Can anyone be kind enough and help me? This was all I could save and it’s stuck.

Sir please if you can help me. I will be very thankful to you. This is seriously a very big issue for me :frowning:

My issue is solved by using VPN. However, I need to switch to several VPN server until the balance showed-up.

About the app version, I reinstalled it and still got the 1.28.1 version.


Hi. I have a similar issue, please help!

I sent BNB from CoinSpot to my Trust Wallet using ‘Bep2’ and now my trust wallet funds are showing zero.

How do I get my funds back?

Thanks in advance!

@Aquarian07, check the related issue here: Transferred BNB from Coinspot to Trust Wallet issues - #14 by iamdeadlyz