Smart contract stuck

I traded some USDT for Kishu Inu yesterday but the money hasn’t left my wallet and the transaction hasn’t taken place. Transaction fee was charged though and is noted as a ‘success’. I’m new to this and have trawled the support pages for a similar problem but mine seems a bit unique. Transaction hash is 0x2c94592d07cdf807fe53cd341eda58a8fa2085c0b5cbe49d39b5fdc642df7397. Wallet version is 5.24 using iOS.

When swapping tokens for the first time, you have to approve it first to be spendable. And, that is what you did just now.

Since you are done approving the token, you need to enter the amount that you want to exchange then press the swap button.

All in all, you will confirm two transactions: approve and swap

Do I have to go back on to uniswap to do that? Apologies for my ignorance.

I tried to do it on uniswap and it said I have insufficient money for the fees. But I already paid a network fee.

@Nmack You paid transaction fee for token approval. Swapping needs transaction fees too.

The costs are outrageous and Trust Wallet needs to make that clearer to potential clients. The fees cost more than the swap I wanted to make and now the fees to withdraw my USDT to Binance are more than the balance. I’ve tried reducing the fee but it doesn’t work. This is a completely unethical company. Telling customers to do their research first wrt fees is outrageous. In essence it’s saying, ‘It’s your fault that you weren’t aware of the predatory platform that is Trust Wallet’. I’m going to report this network.

Trust wallet doesn’t take any fees from transactions.
Learn more here:

  3. How to Change the ETH Gas Fee